summaryrefslogtreecommitdiff
path: root/dev-python/scapy-python3/scapy-python3-0.23.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/scapy-python3/scapy-python3-0.23.ebuild')
-rw-r--r--dev-python/scapy-python3/scapy-python3-0.23.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/scapy-python3/scapy-python3-0.23.ebuild b/dev-python/scapy-python3/scapy-python3-0.23.ebuild
new file mode 100644
index 000000000000..d93a0469a59b
--- /dev/null
+++ b/dev-python/scapy-python3/scapy-python3-0.23.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+IUSE="test"
+inherit distutils-r1
+
+DESCRIPTION="Packet crafting/sending/... PCAP processing tool with python3 compatibility"
+HOMEPAGE="https://pypi.org/project/scapy-python3/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ !net-analyzer/scapy
+ "