summaryrefslogtreecommitdiff
path: root/dev-python/scapy-python3/scapy-python3-0.23.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/scapy-python3/scapy-python3-0.23.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/scapy-python3/scapy-python3-0.23.ebuild')
-rw-r--r--dev-python/scapy-python3/scapy-python3-0.23.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/scapy-python3/scapy-python3-0.23.ebuild b/dev-python/scapy-python3/scapy-python3-0.23.ebuild
new file mode 100644
index 000000000000..d93a0469a59b
--- /dev/null
+++ b/dev-python/scapy-python3/scapy-python3-0.23.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+IUSE="test"
+inherit distutils-r1
+
+DESCRIPTION="Packet crafting/sending/... PCAP processing tool with python3 compatibility"
+HOMEPAGE="https://pypi.org/project/scapy-python3/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ !net-analyzer/scapy
+ "