summaryrefslogtreecommitdiff
path: root/dev-python/sarif_om/sarif_om-1.0.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sarif_om/sarif_om-1.0.4.ebuild')
-rw-r--r--dev-python/sarif_om/sarif_om-1.0.4.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/sarif_om/sarif_om-1.0.4.ebuild b/dev-python/sarif_om/sarif_om-1.0.4.ebuild
new file mode 100644
index 000000000000..8195043438fe
--- /dev/null
+++ b/dev-python/sarif_om/sarif_om-1.0.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Classes implementing the SARIF 2.1.0 object model"
+HOMEPAGE="
+ https://pypi.org/project/sarif-om/
+ https://github.com/microsoft/sarif-python-om/"
+SRC_URI="
+ mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]"