summaryrefslogtreecommitdiff
path: root/dev-python/sabyenc/sabyenc-4.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sabyenc/sabyenc-4.0.1.ebuild')
-rw-r--r--dev-python/sabyenc/sabyenc-4.0.1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/sabyenc/sabyenc-4.0.1.ebuild b/dev-python/sabyenc/sabyenc-4.0.1.ebuild
new file mode 100644
index 000000000000..5445c2513b14
--- /dev/null
+++ b/dev-python/sabyenc/sabyenc-4.0.1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Module providing raw yEnc encoding/decoding for SABnzbd"
+HOMEPAGE="https://github.com/sabnzbd/sabyenc"
+SRC_URI="https://github.com/sabnzbd/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( CHANGES.md README.md doc/yenc-draft.1.3.txt )
+
+distutils_enable_tests pytest