summaryrefslogtreecommitdiff
path: root/dev-python/s3transfer/s3transfer-0.3.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/s3transfer/s3transfer-0.3.1.ebuild')
-rw-r--r--dev-python/s3transfer/s3transfer-0.3.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/s3transfer/s3transfer-0.3.1.ebuild b/dev-python/s3transfer/s3transfer-0.3.1.ebuild
new file mode 100644
index 000000000000..66e665d4201d
--- /dev/null
+++ b/dev-python/s3transfer/s3transfer-0.3.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_6 python3_7 python3_8 )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+
+inherit distutils-r1
+
+DESCRIPTION="An Amazon S3 Transfer Manager"
+HOMEPAGE="https://github.com/boto/s3transfer"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+CDEPEND="
+ dev-python/botocore[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/futures[${PYTHON_USEDEP}]' 'python2_7')
+"
+# Pin mock to 1.3.0 if testing failures due to mock occur.
+DEPEND="
+ test? (
+ ${CDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "tests failed under ${EPYTHON}"
+}
+
+src_prepare() {
+ default
+
+ # Incompatible with recent Future version
+ rm tests/unit/test_s3transfer.py || die
+}