summaryrefslogtreecommitdiff
path: root/dev-python/rsa/rsa-3.4.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/rsa/rsa-3.4.2.ebuild')
-rw-r--r--dev-python/rsa/rsa-3.4.2.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/dev-python/rsa/rsa-3.4.2.ebuild b/dev-python/rsa/rsa-3.4.2.ebuild
deleted file mode 100644
index 43599947175f..000000000000
--- a/dev-python/rsa/rsa-3.4.2.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Pure-Python RSA implementation"
-HOMEPAGE="https://stuvel.eu/rsa https://pypi.org/project/rsa/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/pyasn1-0.1.3[${PYTHON_USEDEP}]
- dev-python/traceback2[${PYTHON_USEDEP}]
- "
-DEPEND="${RDEPEND}
- >=dev-python/setuptools-0.6.10[${PYTHON_USEDEP}]
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/unittest2[${PYTHON_USEDEP}]
- )
- "
-
-python_test() {
- nosetests --verbose || die
-}