summaryrefslogtreecommitdiff
path: root/dev-python/rich
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/rich')
-rw-r--r--dev-python/rich/Manifest2
-rw-r--r--dev-python/rich/rich-13.9.3.ebuild77
2 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/rich/Manifest b/dev-python/rich/Manifest
index 56c1bedf2584..4dc189d22cab 100644
--- a/dev-python/rich/Manifest
+++ b/dev-python/rich/Manifest
@@ -1,3 +1,5 @@
DIST rich-13.9.2.gh.tar.gz 15063908 BLAKE2B c83f736630a7bfbccda7d790476e7a9f518f2fa4e6bb3d4f5190bdeae784571875066c94bd8f4e01117b45a7eee83e9072bb7bb64ab5d5d8675aac5a63d5b0b5 SHA512 468e8f758c374264a77be154dde8908e04502cf8dfdc442dacfaebaaf9f1fbf634ae8dcbcefe42f7562183532a372aebebcdcb03c90031f619a8c5f2cd78f653
+DIST rich-13.9.3.gh.tar.gz 15064090 BLAKE2B 4ef76583ed13692b9f4a9714a68186fd06262e76d691f79cd256b4ab153052efd5fdf2320df797683ea1765cf063215a6b2d2614cd8040ebed0b89178cdcf2e0 SHA512 ca74d59e5df0476b482f60fac8d1f2e0810ffa61a10d410ff188c82548df3307405119f3b18992d96b01458b921ebcd61c99bf68dd808358395e9b04cf78579b
EBUILD rich-13.9.2.ebuild 2098 BLAKE2B dd23a4da2853d4d9b11282c944a3420aac5af0019561644fa3ce3699e58bc91ff06cc6c6ceafe447f7a8d8aabfa43716833bdd24b8bcc79b91745839d9c5acdc SHA512 0d0a197e92749917b7e36c7395c85a9fefa8abd207c4436cb85fda18790ebe150e3151257045377c859f5e749f318e6471ce7fc3101c32422c06929a0aa0db82
+EBUILD rich-13.9.3.ebuild 2106 BLAKE2B 033790ff2ef5358730b05f09c385b3073bec6637fd1375caf97c6b2727cda5abd8dd1408923bcd7751102a2d1b187ec59167fa248d78b012d35d985197d77231 SHA512 35b4dd0743e3a30a7eda2f4d0e340f0b1b99210f3249146b107649f02485d6681eb38f224513ed65cc233635bc729ee0501b2c4c1a3e82fa7fc0c8eaae1d97e1
MISC metadata.xml 387 BLAKE2B 049491e034ba233f33c76dc5e3f1b887ba5d2da9d65b09bda51a7cf4eb30a9c66f3ddf714f52407a73e51da78523084064bccd4fc687e0bc0fc2b32dbb4c513b SHA512 448ce879331748e3166f670981a27ee5c3ef20b51af442ccc684cb6514c0d6a0d4e433a8bc1ddb3bdf68c734bac013c1ba04d38adf90644b062231ab1c1d2c0b
diff --git a/dev-python/rich/rich-13.9.3.ebuild b/dev-python/rich/rich-13.9.3.ebuild
new file mode 100644
index 000000000000..de21ed690f8d
--- /dev/null
+++ b/dev-python/rich/rich-13.9.3.ebuild
@@ -0,0 +1,77 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for rendering rich text, tables, etc. to the terminal"
+HOMEPAGE="
+ https://github.com/Textualize/rich/
+ https://pypi.org/project/rich/
+"
+SRC_URI="
+ https://github.com/Textualize/rich/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ >=dev-python/markdown-it-py-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.13.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.0.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ >=dev-python/attrs-21.4.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_console.py::test_size_can_fall_back_to_std_descriptors
+ # TODO: segfault in recursion (PyQt6 interfering?)
+ tests/test_traceback.py::test_recursive
+ )
+ # version-specific output -- the usual deal
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # pypy3.10, to be more precise
+ tests/test_inspect.py::test_inspect_integer_with_methods_python310only
+ )
+ ;;
+ python3.13)
+ EPYTEST_DESELECT+=(
+ tests/test_inspect.py::test_inspect_builtin_function_except_python311
+ tests/test_inspect.py::test_inspect_integer_with_methods_python38_and_python39
+ tests/test_inspect.py::test_inspect_integer_with_methods_python310only
+ tests/test_inspect.py::test_inspect_integer_with_methods_python311
+ tests/test_pretty.py::test_pretty_dataclass
+ tests/test_pretty.py::test_reference_cycle_dataclass
+ tests/test_pretty.py::test_max_depth_dataclass
+ tests/test_pretty.py::test_attrs_broken
+ )
+ ;;
+ esac
+
+ local -x COLUMNS=80
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+pkg_postinst() {
+ optfeature "integration with HTML widgets for Jupyter" dev-python/ipywidgets
+}