summaryrefslogtreecommitdiff
path: root/dev-python/rich
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/rich')
-rw-r--r--dev-python/rich/Manifest2
-rw-r--r--dev-python/rich/rich-12.6.0.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/rich/Manifest b/dev-python/rich/Manifest
index 63c35a831125..9ba5fe9c33b8 100644
--- a/dev-python/rich/Manifest
+++ b/dev-python/rich/Manifest
@@ -1,3 +1,5 @@
DIST rich-12.5.1.gh.tar.gz 15034345 BLAKE2B 0ff73986d46c70ad6c959bdad2a28e25404bc7f50567f2d559213dfc5341a58b3e3f5e20907275b507f12c107e5d2e947434949ffb7887abad86d4df8cf3ba72 SHA512 41b4328211b825319962056a56df66b86770f62556f84c6c9ad276ae919ec352cda58ecae4535cdca8461913b6be4b8f30d81e0a91cb9a2944a890206215f11f
+DIST rich-12.6.0.gh.tar.gz 15056457 BLAKE2B 58367ef0acb61d68931ea0394ea458e29b3bb59726c6b95d4b179553183c5cef2766484e0d040203181aad927add70198fb3483bfe6113e20851db141de3a867 SHA512 e05a0ad1d6b4f1e4f7e5e3d09c70d5892a618707ae0952e34274c5ffb18a833fe85a4ac15024cc34915515b63059c02f0df32a6c97cbe91e9ac96928c7134fb0
EBUILD rich-12.5.1.ebuild 1484 BLAKE2B a51891d479aad08cb6b3077beaaebdc550917d5f65c254f6445b3ebf446a121e6789178e5c34febb707be699c7dface9c70df548b8d24d0e552b19aaaa114c56 SHA512 490be77fc00accfe30d9076464d5c29a61a838fdde564c94ecd9c42b2ad294fc756d75c89c9eba2fb206138f261b5ac8ecb7cdac0d96fc461bfee47b107443eb
+EBUILD rich-12.6.0.ebuild 1574 BLAKE2B b7385080e05817a31d8e87f4d4de7ccb3c4362918a52a6702d4d375d3184f9f94c5432d6d338026a0e336e4c0bb7bd2c8a0f30abea72efe2fa70c3d63bb33ca9 SHA512 558b64e890c22571d7cd17ee6d7002bc8c70e5210d0c61317c09cf2352cc48f5dab48245649ea7045748e5f9b43e1886160b187090d7ab7e2050d692d1c28749
MISC metadata.xml 387 BLAKE2B 049491e034ba233f33c76dc5e3f1b887ba5d2da9d65b09bda51a7cf4eb30a9c66f3ddf714f52407a73e51da78523084064bccd4fc687e0bc0fc2b32dbb4c513b SHA512 448ce879331748e3166f670981a27ee5c3ef20b51af442ccc684cb6514c0d6a0d4e433a8bc1ddb3bdf68c734bac013c1ba04d38adf90644b062231ab1c1d2c0b
diff --git a/dev-python/rich/rich-12.6.0.ebuild b/dev-python/rich/rich-12.6.0.ebuild
new file mode 100644
index 000000000000..9ba4c176535d
--- /dev/null
+++ b/dev-python/rich/rich-12.6.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for rendering rich text, tables, etc. to the terminal"
+HOMEPAGE="
+ https://github.com/Textualize/rich/
+ https://pypi.org/project/rich/
+"
+SRC_URI="
+ https://github.com/Textualize/rich/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/commonmark[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x COLUMNS=80
+ local EPYTEST_DESELECT=(
+ # broken with >=dev-python/pygments-2.12.0
+ tests/test_console.py::test_size_can_fall_back_to_std_descriptors
+ tests/test_inspect.py::test_inspect_integer_with_methods_python38_and_python39
+ )
+ [[ ${EPYTHON} == python3.11 ]] && EPYTEST_DESELECT+=(
+ # the usual deal: output changes that cause test mismatches
+ tests/test_inspect.py::test_inspect_text
+ tests/test_inspect.py::test_inspect_builtin_function
+ tests/test_inspect.py::test_inspect_integer_with_methods
+ tests/test_log.py::test_log
+ tests/test_pretty.py::test_attrs_broken
+ )
+ epytest -p no:pytest-qt
+}
+
+pkg_postinst() {
+ optfeature "integration with HTML widgets for Jupyter" dev-python/ipywidgets
+}