summaryrefslogtreecommitdiff
path: root/dev-python/rfc3986/rfc3986-2.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/rfc3986/rfc3986-2.0.0.ebuild')
-rw-r--r--dev-python/rfc3986/rfc3986-2.0.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/rfc3986/rfc3986-2.0.0.ebuild b/dev-python/rfc3986/rfc3986-2.0.0.ebuild
new file mode 100644
index 000000000000..ac5f51cdb658
--- /dev/null
+++ b/dev-python/rfc3986/rfc3986-2.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Validating URI References per RFC 3986"
+HOMEPAGE="https://tools.ietf.org/html/rfc3986
+ https://github.com/python-hyper/rfc3986
+ https://rfc3986.rtfd.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="idna"
+
+RDEPEND="
+ idna? ( dev-python/idna[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? ( dev-python/idna[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest