summaryrefslogtreecommitdiff
path: root/dev-python/responses/responses-0.13.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/responses/responses-0.13.4.ebuild')
-rw-r--r--dev-python/responses/responses-0.13.4.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/responses/responses-0.13.4.ebuild b/dev-python/responses/responses-0.13.4.ebuild
new file mode 100644
index 000000000000..2d7e49efc92f
--- /dev/null
+++ b/dev-python/responses/responses-0.13.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Utility for mocking out the Python Requests library"
+HOMEPAGE="https://github.com/getsentry/responses"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/requests-2.0[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.10[${PYTHON_USEDEP}]
+ dev-python/cookies[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest