summaryrefslogtreecommitdiff
path: root/dev-python/requestsexceptions/requestsexceptions-1.4.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/requestsexceptions/requestsexceptions-1.4.0-r1.ebuild')
-rw-r--r--dev-python/requestsexceptions/requestsexceptions-1.4.0-r1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/requestsexceptions/requestsexceptions-1.4.0-r1.ebuild b/dev-python/requestsexceptions/requestsexceptions-1.4.0-r1.ebuild
new file mode 100644
index 000000000000..9730ac75afc0
--- /dev/null
+++ b/dev-python/requestsexceptions/requestsexceptions-1.4.0-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="Finds the correct path to exceptions in the requests library"
+HOMEPAGE="https://github.com/openstack-infra/requestsexceptions"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~riscv x86"
+
+RDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}"