summaryrefslogtreecommitdiff
path: root/dev-python/requests_pkcs12/requests_pkcs12-1.14.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/requests_pkcs12/requests_pkcs12-1.14.ebuild')
-rw-r--r--dev-python/requests_pkcs12/requests_pkcs12-1.14.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/requests_pkcs12/requests_pkcs12-1.14.ebuild b/dev-python/requests_pkcs12/requests_pkcs12-1.14.ebuild
new file mode 100644
index 000000000000..24765222be05
--- /dev/null
+++ b/dev-python/requests_pkcs12/requests_pkcs12-1.14.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+inherit distutils-r1
+
+DESCRIPTION="Adds PKCS#12 support to the Python requests library in a clean way"
+HOMEPAGE="https://github.com/m-click/requests_pkcs12"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND=""
+
+RDEPEND="
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+
+RESTRICT="test" # no tests