summaryrefslogtreecommitdiff
path: root/dev-python/requests/requests-2.18.2-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/requests/requests-2.18.2-r2.ebuild')
-rw-r--r--dev-python/requests/requests-2.18.2-r2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/requests/requests-2.18.2-r2.ebuild b/dev-python/requests/requests-2.18.2-r2.ebuild
new file mode 100644
index 000000000000..f445f7e031f1
--- /dev/null
+++ b/dev-python/requests/requests-2.18.2-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP library for human beings"
+HOMEPAGE="http://python-requests.org/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x64-cygwin ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x64-solaris"
+IUSE="socks5 +ssl test"
+
+RDEPEND="
+ >=dev-python/certifi-2017.4.17[${PYTHON_USEDEP}]
+ >=dev-python/chardet-3.0.2[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.5[${PYTHON_USEDEP}]
+ <dev-python/idna-2.6[${PYTHON_USEDEP}]
+ <dev-python/urllib3-1.23[${PYTHON_USEDEP}]
+ socks5? ( >=dev-python/PySocks-1.5.6[${PYTHON_USEDEP}] )
+ ssl? (
+ >=dev-python/cryptography-1.3.4[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.14[$(python_gen_usedep 'python*' pypy)]
+ )
+"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+# tests connect to various remote sites
+RESTRICT="test"
+# test? (
+# dev-python/pytest[${PYTHON_USEDEP}]
+# dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+# dev-python/pytest-mock[${PYTHON_USEDEP}]
+# dev-python/pytest-xdist[${PYTHON_USEDEP}]
+# )
+
+python_test() {
+ py.test -v --boxed || die
+}