summaryrefslogtreecommitdiff
path: root/dev-python/rencode/rencode-1.0.6-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/rencode/rencode-1.0.6-r3.ebuild')
-rw-r--r--dev-python/rencode/rencode-1.0.6-r3.ebuild24
1 files changed, 15 insertions, 9 deletions
diff --git a/dev-python/rencode/rencode-1.0.6-r3.ebuild b/dev-python/rencode/rencode-1.0.6-r3.ebuild
index 66a639cc8506..e2cc427220b3 100644
--- a/dev-python/rencode/rencode-1.0.6-r3.ebuild
+++ b/dev-python/rencode/rencode-1.0.6-r3.ebuild
@@ -3,20 +3,29 @@
EAPI=8
+DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
DESCRIPTION="similar to bencode from the BitTorrent project"
-HOMEPAGE="https://github.com/aresch/rencode"
-SRC_URI="https://github.com/aresch/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="
+ https://github.com/aresch/rencode/
+ https://pypi.org/project/rencode/
+"
+SRC_URI="
+ https://github.com/aresch/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~ppc ~riscv ~sparc x86 ~amd64-linux ~x86-linux"
-BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
distutils_enable_tests pytest
@@ -28,9 +37,6 @@ PATCHES=(
)
python_test() {
- # The C extension ("_rencode") can't be imported from "${S}/rencode"
- # so we need to cd somewhere else to make sure "rencode" is imported
- # from ${BUILD_DIR}/lib (thanks to PYTHONPATH).
- cd "${T}" || die
- epytest "${S}"
+ rm -rf rencode || die
+ epytest
}