summaryrefslogtreecommitdiff
path: root/dev-python/regex/regex-2021.7.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/regex/regex-2021.7.1.ebuild')
-rw-r--r--dev-python/regex/regex-2021.7.1.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-python/regex/regex-2021.7.1.ebuild b/dev-python/regex/regex-2021.7.1.ebuild
index 271faa2b4fed..c0a5a26d5c4e 100644
--- a/dev-python/regex/regex-2021.7.1.ebuild
+++ b/dev-python/regex/regex-2021.7.1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1 flag-o-matic
DESCRIPTION="Alternative regular expression module to replace re"
@@ -15,6 +15,11 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
IUSE="doc"
+PATCHES=(
+ "${FILESDIR}/${PN}-2021.4.4-pypy3-fix-test_empty_array.patch"
+ "${FILESDIR}/${PN}-2021.4.4-pypy3-fix-test_issue_18468.patch"
+)
+
distutils_enable_tests unittest
python_test() {