summaryrefslogtreecommitdiff
path: root/dev-python/regex/regex-2021.4.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/regex/regex-2021.4.4.ebuild')
-rw-r--r--dev-python/regex/regex-2021.4.4.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-python/regex/regex-2021.4.4.ebuild b/dev-python/regex/regex-2021.4.4.ebuild
index 80f758e55ed2..738d258d1ab9 100644
--- a/dev-python/regex/regex-2021.4.4.ebuild
+++ b/dev-python/regex/regex-2021.4.4.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..10} )
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1 flag-o-matic
@@ -16,6 +16,11 @@ SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
IUSE="doc"
+PATCHES=(
+ "${FILESDIR}/${PN}-2021.4.4-pypy3-fix-test_empty_array.patch"
+ "${FILESDIR}/${PN}-2021.4.4-pypy3-fix-test_issue_18468.patch"
+)
+
distutils_enable_tests unittest
python_test() {