summaryrefslogtreecommitdiff
path: root/dev-python/ramlfications
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ramlfications')
-rw-r--r--dev-python/ramlfications/Manifest3
-rw-r--r--dev-python/ramlfications/metadata.xml24
-rw-r--r--dev-python/ramlfications/ramlfications-0.1.9_p20160718.ebuild45
3 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/ramlfications/Manifest b/dev-python/ramlfications/Manifest
new file mode 100644
index 000000000000..e66f52d61add
--- /dev/null
+++ b/dev-python/ramlfications/Manifest
@@ -0,0 +1,3 @@
+DIST ramlfications-0.1.9_p20160718.tar.gz 1104645 BLAKE2B a33cb4529db10b92280c9ed6bc04e2d4c2d534cc4748ce219984f7fc4c7bc432ad51adc901ea021b64a3776402b159d38cbd34e2c2bca4b863f012026e2b3a0e SHA512 a21330cddb2d390744d7c13ee62edd701f74a83c16f87b897460e2353e265f4171e90e8b51bb0c17762a1f3494ddf8aeaa22c36f0aa093f936b9a51e2d75d1f5
+EBUILD ramlfications-0.1.9_p20160718.ebuild 1184 BLAKE2B e7631aad84325c4c06b04d99001c5a900b9caef4a4d9d2c30523fc6b06caf17678ec5b106e781d00cc730a393498d963b7130bfe416abd4192e6a342a1e64a4d SHA512 99fdb5f7f8065b741b932c4cb0c091ff71fefee1ca886db5f008ac0ed15cae47301124134ae60599bd254858045ab5df86f7591b1e8afb16173c5ca67f69d273
+MISC metadata.xml 798 BLAKE2B 74d1f471f4bc5b36905ed117c764da7a2fa7beff44ecce1f1cf858f64f887ff415d3b298471b05788115f8820e0f987003cc5e197765d8955182dd2ffc4a4a8b SHA512 1702741194e43d4cd938185c638d8eed7bb13180b9914cdb285ae295bee68e3a089caea26d7f3705ce07d2ff1db55353436f5702b0f7a2cfc204c92290c9ab66
diff --git a/dev-python/ramlfications/metadata.xml b/dev-python/ramlfications/metadata.xml
new file mode 100644
index 000000000000..959e9171d0b7
--- /dev/null
+++ b/dev-python/ramlfications/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dolsen@gentoo.org</email>
+ <name>Brian Dolbec</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>spam@lynnroot.com</email>
+ <name>Lynn Root</name>
+ </maintainer>
+ <remote-id type="pypi">ramlfications</remote-id>
+ <remote-id type="github">spotify/ramlfications</remote-id>
+ </upstream>
+ <longdescription>ramlfications is an Apache-2.0 licensed reference implementation
+of a RAML parser in Python intended to be used for parsing API definitions
+(e.g. for static documentation-generation).
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/ramlfications/ramlfications-0.1.9_p20160718.ebuild b/dev-python/ramlfications/ramlfications-0.1.9_p20160718.ebuild
new file mode 100644
index 000000000000..81c18f6ba92d
--- /dev/null
+++ b/dev-python/ramlfications/ramlfications-0.1.9_p20160718.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6})
+
+COMMIT="32a11cd7d75c4c5b3e3fc01c383314be298b0f9b"
+
+inherit eutils distutils-r1
+
+DESCRIPTION="RAML reference implementation in Python"
+HOMEPAGE="https://ramlfications.readthedocs.org/ https://pypi.org/project/ramlfications/"
+SRC_URI="https://github.com/spotify/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/markdown2[${PYTHON_USEDEP}]
+ dev-python/jsonref[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/termcolor[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+python_test() {
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}