summaryrefslogtreecommitdiff
path: root/dev-python/qtconsole/qtconsole-5.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/qtconsole/qtconsole-5.1.0.ebuild')
-rw-r--r--dev-python/qtconsole/qtconsole-5.1.0.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/qtconsole/qtconsole-5.1.0.ebuild b/dev-python/qtconsole/qtconsole-5.1.0.ebuild
deleted file mode 100644
index 97125f3772aa..000000000000
--- a/dev-python/qtconsole/qtconsole-5.1.0.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Qt-based console for Jupyter with support for rich media output"
-HOMEPAGE="https://jupyter.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm64 x86"
-
-RDEPEND="
- dev-python/ipykernel[${PYTHON_USEDEP}]
- dev-python/ipython_genutils[${PYTHON_USEDEP}]
- dev-python/jupyter_core[${PYTHON_USEDEP}]
- >=dev-python/jupyter_client-4.1.1[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/traitlets[${PYTHON_USEDEP}]
- dev-python/QtPy[${PYTHON_USEDEP},gui,printsupport,svg]
-"
-BDEPEND="
- test? (
- dev-python/QtPy[${PYTHON_USEDEP},svg,testlib]
- )
-"
-# required by the tests that are removed:
-# dev-python/flaky[${PYTHON_USEDEP}]
-# dev-python/pytest-qt[${PYTHON_USEDEP}]
-
-PDEPEND="dev-python/ipython[${PYTHON_USEDEP}]"
-
-distutils_enable_sphinx docs/source
-distutils_enable_tests pytest
-
-src_prepare() {
- # TODO: these tests require virtx; however, running under virtx
- # causes pytest to segv on exit (even though tests pass)
- rm qtconsole/tests/test_00_console_widget.py || die
- distutils-r1_src_prepare
-}