summaryrefslogtreecommitdiff
path: root/dev-python/qstylizer
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/qstylizer')
-rw-r--r--dev-python/qstylizer/Manifest2
-rw-r--r--dev-python/qstylizer/qstylizer-0.2.0.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/qstylizer/Manifest b/dev-python/qstylizer/Manifest
index b6139f9aa63c..1bd88aa223a1 100644
--- a/dev-python/qstylizer/Manifest
+++ b/dev-python/qstylizer/Manifest
@@ -1,3 +1,5 @@
DIST qstylizer-0.1.10.tar.gz 20683 BLAKE2B aa12addac6cbe1ebf043d70189683feda87db3a8c2aa3604a04a969f638647ba32eaf7d156559b8af151136aaca784f26025746d9f3e574ad6eb777801bcf44a SHA512 1a747c2a0d5ce0acd220f528bc54c84c723f50bf39fc8d818f6a5475105319f46700d2f00bc5c0f14de8f0caaee0ab8904a379a3e697ca68d00ef62ec3408b2b
+DIST qstylizer-0.2.0.tar.gz 20710 BLAKE2B 1d751efd74e36e665823b64cfd51760bea489ac3916b7ab206d9c9f1fe9adbc0df2dfd9666a79e20c805dabcaa6f3cf4d11074943e0a54b7a6aa93a815c796cf SHA512 094d9c9c14d2000c2c2f2b428cd82a57424507c6df83aa21af3ab7b90e9006761ed131262a2e70a1c4aa4dcea87ac6d07f9137bc224967139467b3f4796ab158
EBUILD qstylizer-0.1.10.ebuild 1533 BLAKE2B 19a49fb724a3db8d99b89c19c8746f661b96ca424443f11e0b32fa8832298f5b037dd2709aac75f0da11f3a398d76417d8fe1a8ecf314d9bd6bb4dfbd1deeee9 SHA512 a0df706d4da862a15cb23f5d8250464421df6e018dfc8808941f493efe5ade7ccc455e96dc033de44fecae34bb9aff7ea602a1c83936660f97105fe3b278f690
+EBUILD qstylizer-0.2.0.ebuild 1538 BLAKE2B b2b08d138a8d1821be7591a0cf436e75bd897fd2a888854b833bf269dfab6e02cacb62272412c62fd8d798058a0d7b6f244173e8e21bc0fd42006f9cc3f9c7f1 SHA512 ced9484dbdb65acc9ed8425cefa268bc8e5e0ec3bb805c0d9a249cafbd492ff8d8c439b26393a76a8ee20025a7d8c770943a37172adbc355337a6f26fb63aa2e
MISC metadata.xml 354 BLAKE2B ea116209c46e48581be418ec1035f3459b375c4fb4623a2af488f98dbde6ddec42eb65f11844477ebe4573366bcb66558c58bc25c50eead585ca70060c0d1195 SHA512 38ac9ffbc6a2ea404f70afd4f0fc3aa8663832116a6182cb05f48736c9f44c4b9211e77c93053e24b1310f0b621784f90ed8261982abba7c6121332593ded18d
diff --git a/dev-python/qstylizer/qstylizer-0.2.0.ebuild b/dev-python/qstylizer/qstylizer-0.2.0.ebuild
new file mode 100644
index 000000000000..36269b58c272
--- /dev/null
+++ b/dev-python/qstylizer/qstylizer-0.2.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Stylesheet Generator for PyQt5/PySide2"
+HOMEPAGE="https://github.com/blambright/qstylizer"
+SRC_URI="https://github.com/blambright/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/tinycss2-0.5[${PYTHON_USEDEP}]
+ <dev-python/tinycss2-2[${PYTHON_USEDEP}]
+ >=dev-python/inflection-0.3.0[${PYTHON_USEDEP}]
+ <dev-python/inflection-1[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ dev-vcs/git
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc dev-python/sphinx_rtd_theme dev-python/sphinxcontrib-autoprogram
+
+python_prepare_all() {
+ # Exception: Versioning for this project requires either an sdist tarball, or access to an
+ # upstream git repository. It's also possible that there is a mismatch between the package
+ # name in setup.cfg and the argument given to pbr.version.VersionInfo. Project name qstylizer
+ # was given, but was not able to be found.
+ #
+ # There are no tarballs on PyPI, so we do this as a workaround
+ git init -q || die
+ git config user.email "larry@gentoo.org" || die
+ git config user.name "Larry the Cow" || die
+ git add . || die
+ git commit -m "init" || die
+ git tag -a "${PV}" -m "${PV}" || die
+
+ distutils-r1_python_prepare_all
+}