summaryrefslogtreecommitdiff
path: root/dev-python/pyzmq
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyzmq')
-rw-r--r--dev-python/pyzmq/Manifest4
-rw-r--r--dev-python/pyzmq/metadata.xml1
-rw-r--r--dev-python/pyzmq/pyzmq-25.0.0.ebuild90
3 files changed, 94 insertions, 1 deletions
diff --git a/dev-python/pyzmq/Manifest b/dev-python/pyzmq/Manifest
index 3bd78895cc18..e6dc077c4804 100644
--- a/dev-python/pyzmq/Manifest
+++ b/dev-python/pyzmq/Manifest
@@ -1,4 +1,6 @@
AUX pyzmq-23.2.0-libdir.patch 510 BLAKE2B cb7884416d3e15f735412d69a7ae0decbbf8eca14ae909b23e68231a65b3ad36d021b5c6f5315a3cb982cd571913ce021cc5df60509d90b28d4353dd7bd316e8 SHA512 f268d03de45971d50a89210366b4aef0e79e652a45d650fc3e4a6711558ee186ee558a2808b7c9f5c5a64ce8b9282adf024ab21a782ba614900a4813e8b6d6ca
DIST pyzmq-24.0.1.gh.tar.gz 404000 BLAKE2B 01928ba3c64a5afce8e7a97821658da2067a5f6c36c0173ab2f818e83a729939f346ef67bb9a39251abf365f5772abdf7e9e62afb4cc434b5603f474485a7427 SHA512 d4b6346e780f356941a624321f1619771fb2f0ef9f65a3c0a03e837ef081ece7ed59c03f57e8647ab1cd38cfc7404d597dd294768f9e9b890115b9eebc085484
+DIST pyzmq-25.0.0.gh.tar.gz 387190 BLAKE2B aba258637fa698e3e2241c36b561d76971a82d20137573ed75bacf429cd21e2f2cbf6c15c76e7c6a9f2e3d7acd7cb03e5091f71bb41d6365c93d670a2cc81392 SHA512 9a4f25f6a9f6a9e636c7d50af69ee9d4629503fd707f6cd17772430f71bd386a573e5eed19eca0419ce0a3ca1f811601c785b5b6b9749b5cf03654a97c2afaf6
EBUILD pyzmq-24.0.1.ebuild 1948 BLAKE2B f0051c2fb48dffe371d7284f94b66cecc8195a02c8ab2b97adf134f240c8deecf3bba5f8ad77f747c5131681ffd2ad90686df873d5a57968c92d4ff30f21e3df SHA512 1ca085f6f74c43868b43a06ee6f23d188305b316913e30e81cf1cca431eb596d6f33f081bd2539ccfe78afa83c562c89db9596cd4adec0e10c6469d00f478337
-MISC metadata.xml 548 BLAKE2B 0120b82c6a48537f80d08237f4184ff855c109a0a461adfe7921e25468928ea053cc7727c7b00ff96ea556d719e453ee27cf534b285f24f62f7d1ca4ab326770 SHA512 124145f71518d39daa57522eadc27ab4782c3fc1794543396a6b6c91dda29175c4c097d6be90d7d405823621ce66f62e169b97e086c983d7f08178e6d85cee40
+EBUILD pyzmq-25.0.0.ebuild 2220 BLAKE2B d4d04a78a7c1d60aa1884a465aa543461411d8f0c4adc14bb4544a6486f0e1ed0384255f0e229c28d9769c7f7aebf7d8cca6dbf108ab0fe68c195b9973516f69 SHA512 408482a624be3b2af94204b2f8910781437fdbb28e8135c369f950532f622e62ebff65655bb5ffb3bdd5c33562b51a9b0e2433238386b7be0354c5d750106baf
+MISC metadata.xml 602 BLAKE2B 2dcde66f620e979bf1c13ffb8becbb933e39d9737ab88e53f5534ab5474820ad28d8ee71a42685fe0ebe11499095276c6cbf0f2cda003e23c00b899934b19e36 SHA512 67bb10383483c87f479ef57af47a46b211d1036184819c3f43bc9f8d1e6310f168a6cc8853984e5a77e81a05d93858da9b246fc92d42cb5a4d08bca46085ac3c
diff --git a/dev-python/pyzmq/metadata.xml b/dev-python/pyzmq/metadata.xml
index f3cb0b82106a..8b18d4ba0094 100644
--- a/dev-python/pyzmq/metadata.xml
+++ b/dev-python/pyzmq/metadata.xml
@@ -15,5 +15,6 @@
</upstream>
<use>
<flag name="draft">Enable draft API support</flag>
+ <flag name="drafts">Enable draft API support</flag>
</use>
</pkgmetadata>
diff --git a/dev-python/pyzmq/pyzmq-25.0.0.ebuild b/dev-python/pyzmq/pyzmq-25.0.0.ebuild
new file mode 100644
index 000000000000..62e3e834ee47
--- /dev/null
+++ b/dev-python/pyzmq/pyzmq-25.0.0.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+# TODO: Find out exactly where this error comes from
+# error: '<' not supported between instances of 'str' and 'int'
+#DISTUTILS_USE_PEP517=setuptools
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Lightweight and super-fast messaging library built on top of the ZeroMQ library"
+HOMEPAGE="
+ https://zeromq.org/languages/python/
+ https://pypi.org/project/pyzmq/
+ https://github.com/zeromq/pyzmq/"
+SRC_URI="
+ https://github.com/zeromq/pyzmq/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="drafts"
+
+# There are additional test failures if zeromq has the draft api enabled, but pyzmq has it disabled.
+DEPEND="
+ >=net-libs/zeromq-4.2.2-r2:=[drafts=]
+"
+# It uses cffi backend for pypy, cython backend for cpython
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/py[${PYTHON_USEDEP}]
+ dev-python/cffi:=[${PYTHON_USEDEP}]
+ ' pypy3)
+"
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_USEDEP}]
+ ' 'python*')
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ >=dev-python/tornado-5.0.2[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-23.2.0-libdir.patch
+)
+
+EPYTEST_DESELECT=(
+ # TODO
+ zmq/tests/test_constants.py::TestConstants::test_draft
+ zmq/tests/test_cython.py::test_cython
+
+ # Hangs often
+ zmq/tests/test_log.py::TestPubLog::test_blank_root_topic
+)
+
+EPYTEST_IGNORE=(
+ # Avoid dependency on mypy
+ zmq/tests/test_mypy.py
+
+ # Broken upstream
+ zmq/tests/test_auth.py
+
+ # pytest-asyncio incompatibility?
+ zmq/tests/test_zmqstream.py
+)
+
+distutils_enable_tests pytest
+# TODO: Package enum_tools
+# distutils_enable_sphinx docs/source \
+# dev-python/numpydoc \
+# dev-python/sphinx-rtd-theme \
+# dev-python/myst_parser
+
+python_prepare_all() {
+ export ZMQ_DRAFT_API=$(usex drafts '1' '0')
+ export ZMQ_PREFIX="${EPREFIX}/usr"
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cd "${BUILD_DIR}/lib" || die
+ epytest -p no:flaky
+}