summaryrefslogtreecommitdiff
path: root/dev-python/pyzbar/pyzbar-0.1.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyzbar/pyzbar-0.1.8.ebuild')
-rw-r--r--dev-python/pyzbar/pyzbar-0.1.8.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pyzbar/pyzbar-0.1.8.ebuild b/dev-python/pyzbar/pyzbar-0.1.8.ebuild
new file mode 100644
index 000000000000..ce26eac62812
--- /dev/null
+++ b/dev-python/pyzbar/pyzbar-0.1.8.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read one-dimensional barcodes and QR codes from Python"
+HOMEPAGE="https://github.com/NaturalHistoryMuseum/pyzbar/"
+SRC_URI="https://github.com/NaturalHistoryMuseum/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/pillow[${PYTHON_USEDEP}]
+ media-gfx/zbar
+ virtual/python-enum34[${PYTHON_USEDEP}]
+ virtual/python-pathlib[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}
+ test? (
+ virtual/python-unittest-mock[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest