summaryrefslogtreecommitdiff
path: root/dev-python/pyyaml
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyyaml')
-rw-r--r--dev-python/pyyaml/Manifest2
-rw-r--r--dev-python/pyyaml/pyyaml-6.0.2_rc1.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/pyyaml/Manifest b/dev-python/pyyaml/Manifest
index 76848d144aca..a57438ddc5f6 100644
--- a/dev-python/pyyaml/Manifest
+++ b/dev-python/pyyaml/Manifest
@@ -1,4 +1,6 @@
AUX pyyaml-6.0.1-cython3.patch 1423 BLAKE2B ff93a6bc36d0ca7b85a3c3c5cf67c57c600334b817cd52db5336a52427bd41bf667aa42405eb4c539eb8024b2b8533462f50da439def3be53bdedabfe9459ac4 SHA512 9ad485f625c859b67cefb45cd3f5cdd3304117c9d2b7e926f157b0b127805fad6ef83783fbead1e53e536eeafc60570eb1a75b309835de136c386faa8ba6f6c0
DIST pyyaml-6.0.1.gh.tar.gz 120376 BLAKE2B c34f2169f6eb6aa718aeb53dbfaf02590e11e504d16cc85a802e1a1191f296ef9aa2501db683e1a48173ce6adeaeca09f2ab989581dcf1c1ba4004831bb4cf47 SHA512 1c74a92a4ad7d47854dc7bcb2e89b3c8e0b14fa815c7dbfbc22b24480dbba6c81e971c77ee384c494a960914b95f06edf943d7431925a5ed674a0ba830d258e0
+DIST pyyaml-6.0.2rc1.gh.tar.gz 123879 BLAKE2B 9d983338c4e61fa6f5056aa7733dadc854a859baffe3ad5a353d6fc0525b6c5788df7e85ab40514ad8bdeffbccf10417701fdaac4d0985e0a20b300867b89f4f SHA512 4eac37f3b367099e93c53f327f5f838d5f2f06fa636ea08f277a6cf4f570b7dc9870b35057a889d0895c2abd1bfc121d624f282610dcf90e68727973573267ef
EBUILD pyyaml-6.0.1-r1.ebuild 1052 BLAKE2B 59d64510f2b97537efbff4c7e927b323df1c6259565acc3f3e443c46219abc5851eed8b1b9bede020e14a422aa80925109f79fe15a8a4d8c8e7f2d323222f3e8 SHA512 a1e911e0b33bda3a446612c4cbd53be2d1657bf884f015d91278e03cd4433536ed350b46369e1976bbd7147d11e7ff990443d8ed9be96ea878c407fcba634815
+EBUILD pyyaml-6.0.2_rc1.ebuild 1441 BLAKE2B 3dfe19c2045d542e2abf44d426141d511fd6078a52814421e2570899b4e5d3e1cb9711c445904b276df4137b868a91026be48f7244bae9c49c01891a3a992b4f SHA512 1c5bbee91f8a631e81f77c658d573f96ce2ccd62c65a38289f99251a7a02f8036d7370b711ed143f7fbcdcfeb6d3248ce2fd0f4e97af5a388feebe65b77ce511
MISC metadata.xml 426 BLAKE2B 6216e38c3e79e811aced6c777b49779953abf4f1b0a1185947f6a6fdc851fdf4cc973092024a6cb2d76bf06863feb49742c7a6892a8761b48a5e74902757a610 SHA512 f549b70fcf1588625fcc2bc33ad0c41faa267ad5bb84d564f5502dee1ad2340a663d1a2b92cf9fdeed827a5f7cebdbe76d59166e89de6d03e7933141029c051d
diff --git a/dev-python/pyyaml/pyyaml-6.0.2_rc1.ebuild b/dev-python/pyyaml/pyyaml-6.0.2_rc1.ebuild
new file mode 100644
index 000000000000..9be8de2241fe
--- /dev/null
+++ b/dev-python/pyyaml/pyyaml-6.0.2_rc1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1
+
+MY_P=${P/_}
+DESCRIPTION="YAML parser and emitter for Python"
+HOMEPAGE="
+ https://pyyaml.org/wiki/PyYAML
+ https://pypi.org/project/PyYAML/
+ https://github.com/yaml/pyyaml/
+"
+SRC_URI="
+ https://github.com/yaml/pyyaml/archive/${PV/_}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="examples"
+
+DEPEND="
+ dev-libs/libyaml:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+src_configure() {
+ export PYYAML_FORCE_CYTHON=1
+}
+
+python_test() {
+ local -x PATH="${BUILD_DIR}/test${EPREFIX}/usr/bin:${PATH}"
+ local -x PYTHONPATH="tests/legacy_tests:${PYTHONPATH}"
+ # upstream indicates testing may pollute the package
+ cp -a "${BUILD_DIR}"/{install,test} || die
+ "${BUILD_DIR}"/test/usr/bin/python <<-EOF || die "Tests failed on ${EPYTHON}"
+ import sys
+ import test_all
+ sys.exit(0 if test_all.main() else 1)
+ EOF
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}
+ fi
+}