summaryrefslogtreecommitdiff
path: root/dev-python/pywlroots
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pywlroots')
-rw-r--r--dev-python/pywlroots/Manifest4
-rw-r--r--dev-python/pywlroots/files/pywlroots-0.15.24-no-import-version-check.patch13
-rw-r--r--dev-python/pywlroots/metadata.xml11
-rw-r--r--dev-python/pywlroots/pywlroots-0.15.24.ebuild44
4 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/pywlroots/Manifest b/dev-python/pywlroots/Manifest
new file mode 100644
index 000000000000..09783ad26b8b
--- /dev/null
+++ b/dev-python/pywlroots/Manifest
@@ -0,0 +1,4 @@
+AUX pywlroots-0.15.24-no-import-version-check.patch 592 BLAKE2B 24ef9a82a3a7c62e8b0669cd25e6cd984a633ebf8f276436f48d54f6064119cceffe400a8c386e6407f3063fa678bab10d4151e0a5976041eab0ff36a16b7c6b SHA512 4a93ebad7670ba6ff41e68030b33a15d7545f244fa5b982fc3dd12c3a349e70f2e59267c9d6f2383a80e2376243118cc46bb4b3d9027abbe3cd9d69d1be5ebf8
+DIST pywlroots-0.15.24.gh.tar.gz 85570 BLAKE2B 0c7ba0be6159152488785298028bb1feec20e2380357060a850dab417b3fb1fccb4a9e6cc6564d2b7f124bf4fc454789549267e9036b0b4559e5fcd4c6f06196 SHA512 b29b76cf18a65b2ef19d15ecf018a9ba44119d60ee61435967d17f06d5f7544d2117f2e9a81574734c71591a237b00c8584a5cc6d6adb928f39f11170f21ee94
+EBUILD pywlroots-0.15.24.ebuild 897 BLAKE2B 5c39790e864ee3f165db5d525d5c93f0b02002c28a6af5fbf5bffae3370655f5b45728ca4c8aa1fd0449cb4406aa94604778990ec50cf6575ec767c1abee8fde SHA512 773736e8397c60b55bc9e838da0ad6aa99bd4255a455ab7578816651576b345faba025da11e95df3189c6fb48e2d7679dc10c64a00706148f737b3dad104da02
+MISC metadata.xml 351 BLAKE2B 8c8ef3ef1d58928c0a15fcd756e4d1c94b2793626c9b4e9cbeb31443119cb47fa4975063547065cbc6e06f327ec7d36beb5e74973fd3d372ad4f7feeac3410ea SHA512 b4840e4149647c29e358b64d3de99a0f2b148a4d7d123d7ef7df67cf918a3f599d3e199ed7ef4d0d39bf8ccc8e4630058db4ae3a2260119ce1c5d255bf2dd9c8
diff --git a/dev-python/pywlroots/files/pywlroots-0.15.24-no-import-version-check.patch b/dev-python/pywlroots/files/pywlroots-0.15.24-no-import-version-check.patch
new file mode 100644
index 000000000000..eb0cce91ac35
--- /dev/null
+++ b/dev-python/pywlroots/files/pywlroots-0.15.24-no-import-version-check.patch
@@ -0,0 +1,13 @@
+https://github.com/flacjacket/gentoo-overlay/blob/master/dev-python/pywlroots/files/pywlroots-no_version_check.patch
+
+This causes sandbox failures in e.g. qtile on importing pywlroots.
+--- a/wlroots/ffi_build.py
++++ b/wlroots/ffi_build.py
+@@ -44,6 +44,7 @@ def load_wlroots_version():
+
+ def check_version():
+ """Check for wlroots version compatibility"""
++ return
+ # When importing a system-level installed package, we may not be able to
+ # create neighboring files, which is done by the `.verify` step. If this
+ # error is hit, we check with the compiled `wlroots.lib`.
diff --git a/dev-python/pywlroots/metadata.xml b/dev-python/pywlroots/metadata.xml
new file mode 100644
index 000000000000..34ba1c191606
--- /dev/null
+++ b/dev-python/pywlroots/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">flacjacket/pywlroots</remote-id>
+ <remote-id type="pypi">pywlroots</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pywlroots/pywlroots-0.15.24.ebuild b/dev-python/pywlroots/pywlroots-0.15.24.ebuild
new file mode 100644
index 000000000000..5bd07ae0e059
--- /dev/null
+++ b/dev-python/pywlroots/pywlroots-0.15.24.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python binding to the wlroots library using cffi"
+HOMEPAGE="
+ https://github.com/flacjacket/pywlroots
+ https://pypi.org/project/pywlroots/
+"
+SRC_URI="
+ https://github.com/flacjacket/pywlroots/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# See README for wlroots dep
+RDEPEND="
+ >=dev-python/pywayland-0.4.14[${PYTHON_USEDEP}]
+ >=dev-python/xkbcommon-0.2[${PYTHON_USEDEP}]
+ =gui-libs/wlroots-$(ver_cut 1-2)*:=
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.15.24-no-import-version-check.patch
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ # No die deliberately as sometimes it doesn't exist
+ rm -r wlroots
+
+ epytest
+}