summaryrefslogtreecommitdiff
path: root/dev-python/pyusb/pyusb-1.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyusb/pyusb-1.2.1.ebuild')
-rw-r--r--dev-python/pyusb/pyusb-1.2.1.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-python/pyusb/pyusb-1.2.1.ebuild b/dev-python/pyusb/pyusb-1.2.1.ebuild
index 900eb0c4252d..d7c303722986 100644
--- a/dev-python/pyusb/pyusb-1.2.1.ebuild
+++ b/dev-python/pyusb/pyusb-1.2.1.ebuild
@@ -3,12 +3,11 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..10} )
-inherit distutils-r1
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1 pypi
DESCRIPTION="USB support for Python"
HOMEPAGE="https://pyusb.github.io/pyusb/ https://pypi.org/project/pyusb/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
@@ -20,6 +19,10 @@ RDEPEND="${DEPEND}"
DOCS=( README.rst docs/tutorial.rst )
+PATCHES=(
+ "${FILESDIR}"/${P}-setuptools.patch
+)
+
python_test() {
cd tests || die
"${EPYTHON}" testall.py || die "Tests failed with ${EPYTHON}"