summaryrefslogtreecommitdiff
path: root/dev-python/pyusb/pyusb-1.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyusb/pyusb-1.2.0.ebuild')
-rw-r--r--dev-python/pyusb/pyusb-1.2.0.ebuild26
1 files changed, 0 insertions, 26 deletions
diff --git a/dev-python/pyusb/pyusb-1.2.0.ebuild b/dev-python/pyusb/pyusb-1.2.0.ebuild
deleted file mode 100644
index 24e01cf2f163..000000000000
--- a/dev-python/pyusb/pyusb-1.2.0.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="USB support for Python"
-HOMEPAGE="https://pyusb.github.io/pyusb/ https://pypi.org/project/pyusb/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
-
-### This version is compatible with both 0.X and 1.X versions of libusb
-DEPEND="virtual/libusb:="
-RDEPEND="${DEPEND}"
-
-DOCS=( README.rst docs/tutorial.rst )
-
-python_test() {
- cd tests || die
- "${EPYTHON}" testall.py || die "Tests failed with ${EPYTHON}"
-}