summaryrefslogtreecommitdiff
path: root/dev-python/pytz/pytz-2021.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytz/pytz-2021.1.ebuild')
-rw-r--r--dev-python/pytz/pytz-2021.1.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-python/pytz/pytz-2021.1.ebuild b/dev-python/pytz/pytz-2021.1.ebuild
deleted file mode 100644
index 6300dfc3d37d..000000000000
--- a/dev-python/pytz/pytz-2021.1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="World timezone definitions for Python"
-HOMEPAGE="https://pythonhosted.org/pytz/ https://pypi.org/project/pytz/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE=""
-
-DEPEND="
- || ( >=sys-libs/timezone-data-2017a sys-libs/glibc[vanilla] )"
-RDEPEND="${DEPEND}"
-BDEPEND="app-arch/unzip"
-
-PATCHES=(
- # Use timezone-data zoneinfo.
- "${FILESDIR}"/pytz-2020.5-system-zoneinfo.patch
-)
-
-python_test() {
- "${EPYTHON}" pytz/tests/test_tzinfo.py -v || die "Tests fail with ${EPYTHON}"
-}