summaryrefslogtreecommitdiff
path: root/dev-python/pytools/pytools-2021.2.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytools/pytools-2021.2.8.ebuild')
-rw-r--r--dev-python/pytools/pytools-2021.2.8.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/pytools/pytools-2021.2.8.ebuild b/dev-python/pytools/pytools-2021.2.8.ebuild
new file mode 100644
index 000000000000..5400173d9dde
--- /dev/null
+++ b/dev-python/pytools/pytools-2021.2.8.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE='sqlite'
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of tools missing from the Python standard library"
+HOMEPAGE="https://mathema.tician.de/software/pytools/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.6.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest