summaryrefslogtreecommitdiff
path: root/dev-python/python_orocos_kdl/python_orocos_kdl-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python_orocos_kdl/python_orocos_kdl-9999.ebuild')
-rw-r--r--dev-python/python_orocos_kdl/python_orocos_kdl-9999.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/dev-python/python_orocos_kdl/python_orocos_kdl-9999.ebuild b/dev-python/python_orocos_kdl/python_orocos_kdl-9999.ebuild
index 12ffb7c93b4f..a3114345ba43 100644
--- a/dev-python/python_orocos_kdl/python_orocos_kdl-9999.ebuild
+++ b/dev-python/python_orocos_kdl/python_orocos_kdl-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{3_7,3_8,3_9} )
+PYTHON_COMPAT=( python{3_8,3_9,3_10} )
SCM=""
if [ "${PV#9999}" != "${PV}" ] ; then
@@ -29,7 +29,7 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="
${PYTHON_DEPS}
>=sci-libs/orocos_kdl-1.4.0:=
- <dev-python/sip-5[${PYTHON_USEDEP}]"
+ dev-python/pybind11[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}"
if [ "${PV#9999}" != "${PV}" ] ; then
@@ -38,6 +38,14 @@ else
S=${WORKDIR}/orocos_kinematics_dynamics-${PV}/python_orocos_kdl
fi
+src_prepare() {
+ sed -e 's/find_package(catkin/find_package(NoTcatkin/' \
+ -e 's/add_subdirectory(pybind11/find_package(pybind11/' \
+ -e 's/dist-packages/site-packages/' \
+ -i CMakeLists.txt || die
+ cmake_src_prepare
+}
+
src_configure() {
python_foreach_impl cmake_src_configure
}
@@ -52,8 +60,4 @@ src_test() {
src_install() {
python_foreach_impl cmake_src_install
-
- # Need to have package.xml in our custom gentoo path
- insinto /usr/share/ros_packages/${PN}
- doins "${ED}/usr/share/${PN}/package.xml"
}