summaryrefslogtreecommitdiff
path: root/dev-python/python3-xapp/python3-xapp-2.4.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python3-xapp/python3-xapp-2.4.0.ebuild')
-rw-r--r--dev-python/python3-xapp/python3-xapp-2.4.0.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/python3-xapp/python3-xapp-2.4.0.ebuild b/dev-python/python3-xapp/python3-xapp-2.4.0.ebuild
new file mode 100644
index 000000000000..b3eb90892128
--- /dev/null
+++ b/dev-python/python3-xapp/python3-xapp-2.4.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9,10,11} )
+
+inherit meson python-r1
+
+DESCRIPTION="Python bindings for x11-libs/xapp"
+HOMEPAGE="https://github.com/linuxmint/python3-xapp"
+SRC_URI="https://github.com/linuxmint/python3-xapp/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ >=x11-libs/xapp-2.4.1[introspection]
+"
+RDEPEND="
+ ${DEPEND}
+ ${PYTHON_DEPS}
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+
+src_prepare() {
+ echo "option('python', type: 'string', value: 'python3')" >> meson_options.txt
+ sed -i "s/find_installation('python3')/find_installation(get_option('python'))/" meson.build || die
+ default
+}
+
+src_configure() {
+ configuring() {
+ meson_src_configure \
+ -Dpython="${EPYTHON}"
+ }
+ python_foreach_impl configuring
+}
+
+src_compile() {
+ python_foreach_impl meson_src_compile
+}
+
+src_install() {
+ installing() {
+ meson_src_install
+ python_optimize
+ }
+ python_foreach_impl installing
+}