summaryrefslogtreecommitdiff
path: root/dev-python/python-xmlsec/python-xmlsec-1.3.11.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-xmlsec/python-xmlsec-1.3.11.ebuild')
-rw-r--r--dev-python/python-xmlsec/python-xmlsec-1.3.11.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/dev-python/python-xmlsec/python-xmlsec-1.3.11.ebuild b/dev-python/python-xmlsec/python-xmlsec-1.3.11.ebuild
index 2cdbbac944bb..a43d02473ec7 100644
--- a/dev-python/python-xmlsec/python-xmlsec-1.3.11.ebuild
+++ b/dev-python/python-xmlsec/python-xmlsec-1.3.11.ebuild
@@ -1,9 +1,9 @@
# Copyright 2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Python bindings for the XML Security Library"
@@ -23,11 +23,13 @@ RDEPEND="${DEPEND}
BDEPEND="${RDEPEND}
dev-python/pkgconfig[${PYTHON_USEDEP}]
dev-python/wheel[${PYTHON_USEDEP}]
-"
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )"
-# tests fail, has been reported upstream
-# https://github.com/mehcode/python-xmlsec/issues/84
-RESTRICT=test
+PATCHES=(
+ "${FILESDIR}/${P}-fix-xml-testfail.patch"
+)
distutils_enable_tests pytest