summaryrefslogtreecommitdiff
path: root/dev-python/python-utils/python-utils-2.5.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-utils/python-utils-2.5.2.ebuild')
-rw-r--r--dev-python/python-utils/python-utils-2.5.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/python-utils/python-utils-2.5.2.ebuild b/dev-python/python-utils/python-utils-2.5.2.ebuild
new file mode 100644
index 000000000000..b83efbe8075e
--- /dev/null
+++ b/dev-python/python-utils/python-utils-2.5.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} pypy3)
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of small Python functions & classes"
+HOMEPAGE="https://pypi.org/project/python-utils/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -i -e '/--cov/d' -e '/--flake8/d' pytest.ini || die
+ distutils-r1_python_prepare_all
+}