summaryrefslogtreecommitdiff
path: root/dev-python/python-systemd/python-systemd-234.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-systemd/python-systemd-234.ebuild')
-rw-r--r--dev-python/python-systemd/python-systemd-234.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-python/python-systemd/python-systemd-234.ebuild b/dev-python/python-systemd/python-systemd-234.ebuild
index 978b842ca4bc..14dc2725969d 100644
--- a/dev-python/python-systemd/python-systemd-234.ebuild
+++ b/dev-python/python-systemd/python-systemd-234.ebuild
@@ -27,9 +27,17 @@ RDEPEND="${COMMON_DEPEND}
"
PATCHES=(
-# "${FILESDIR}"/233-xfail-bind.patch
)
+python_compile() {
+ if python_is_python3; then
+ # https://bugs.gentoo.org/690316
+ distutils-r1_python_compile -j1
+ else
+ distutils-r1_python_compile
+ fi
+}
+
python_test() {
pushd "${BUILD_DIR}/lib" > /dev/null || die
pytest -o cache_dir="${T}" -vv || die