summaryrefslogtreecommitdiff
path: root/dev-python/python-stdnum/python-stdnum-1.16.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-stdnum/python-stdnum-1.16.ebuild')
-rw-r--r--dev-python/python-stdnum/python-stdnum-1.16.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/python-stdnum/python-stdnum-1.16.ebuild b/dev-python/python-stdnum/python-stdnum-1.16.ebuild
new file mode 100644
index 000000000000..7ee9a4124ff7
--- /dev/null
+++ b/dev-python/python-stdnum/python-stdnum-1.16.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A module to handle standardized numbers and codes"
+HOMEPAGE="https://arthurdejong.org/python-stdnum/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="vies"
+
+RDEPEND="
+ vies? (
+ || (
+ dev-python/zeep[${PYTHON_USEDEP}]
+ dev-python/suds[${PYTHON_USEDEP}]
+ )
+ )"
+
+DOCS=( ChangeLog NEWS README )
+
+distutils_enable_tests nose