summaryrefslogtreecommitdiff
path: root/dev-python/python-redmine
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-redmine')
-rw-r--r--dev-python/python-redmine/Manifest2
-rw-r--r--dev-python/python-redmine/python-redmine-2.5.0.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/python-redmine/Manifest b/dev-python/python-redmine/Manifest
index 80350db0a36e..e61315a62dfb 100644
--- a/dev-python/python-redmine/Manifest
+++ b/dev-python/python-redmine/Manifest
@@ -1,3 +1,5 @@
DIST python-redmine-2.4.0.tar.gz 67730 BLAKE2B 22c74ad194af9b56affab39de38b13a8f5a46e79b8ea8d9f9f47eb12c4ad4c91156db9ef0e8dfd013602b8cc06e0636a724ae34969f385dc9f8ffc63514ccc63 SHA512 afb03ca8a3bdacace3c12b7295ba08953ab2040971b57988deb9955df24e5ac1782a9b3fbf0f5070eb22c640e88f489cda12cdec38449f9e3bcf7189dc422642
+DIST python-redmine-2.5.0.tar.gz 73643 BLAKE2B aae400a68385fa98d454820081abacfabe69be473de8ee21feb47dfd8b3372cb0b8dfca168fc9daebd37da04a4fcca84235eb555262489dc1b717fd589dc849a SHA512 8c610efe5e4362ab27a33a04e78347e2962b9e766cea81c725b5b34bdff1d2c6a2e68e5d928b5aed97af569f5c6656dc2b39347a76cb371a3069bba3fd02c8e2
EBUILD python-redmine-2.4.0.ebuild 739 BLAKE2B e1705c75583066140543f8bc38f6a8ddb6cbd9a06958a8cfb6d8f85d90c68ec9bd29631f549c3fb52a3a10eb25a56460f733faac5e088b0bee4b172ae312dc9d SHA512 f04928d69b99816593598f33f2fecde7c90716c91cb2daeadf54241ce7a49dc3043eb0ee3da496c8afde0e90ed127e7a259cffc25d65373a2a9bfad8664ba4d5
+EBUILD python-redmine-2.5.0.ebuild 739 BLAKE2B 3fbc70e33fc984cf28bf6814e2675e7779af16b764edbafeefd4ca68868381aa1b9cb1b13151a7bc1ab48f778c69f0589c46cf0fdc69092efb402ac23a5f2ec5 SHA512 9bfb52bd7526c7209374533b51372e90f2caedd108e8fb24e5bfd879df265e3439028a7d2d6893d1b2b300cb127b12895dcf722602850e51bec18791d2f15e78
MISC metadata.xml 426 BLAKE2B 4b854d12e2cd5977800ee0ba114e1e8cf3895afc412d50b7ca9101842c3430a076e8daa07ae58624e3ae25163cf49de5924f9df7735550903f79ffbebbdd3763 SHA512 e56e41d36e3fbb82ec4b592ec3c6b4a69669bf79c159a97045b7643676361208885ec18a0dfd2462a8f456435d5ec51250b893693f9411c727e8bd44c8a4ae92
diff --git a/dev-python/python-redmine/python-redmine-2.5.0.ebuild b/dev-python/python-redmine/python-redmine-2.5.0.ebuild
new file mode 100644
index 000000000000..8219293367ea
--- /dev/null
+++ b/dev-python/python-redmine/python-redmine-2.5.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python interface to the Redmine REST API"
+HOMEPAGE="
+ https://github.com/maxtepkeev/python-redmine/
+ https://pypi.org/project/python-redmine/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/requests-2.28.2[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # https://github.com/maxtepkeev/python-redmine/pull/332
+ sed -i -e 's:assertEquals:assertEqual:' tests/*.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ epytest -o addopts=
+}