summaryrefslogtreecommitdiff
path: root/dev-python/python-ptrace/python-ptrace-0.8.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-ptrace/python-ptrace-0.8.1-r1.ebuild')
-rw-r--r--dev-python/python-ptrace/python-ptrace-0.8.1-r1.ebuild30
1 files changed, 0 insertions, 30 deletions
diff --git a/dev-python/python-ptrace/python-ptrace-0.8.1-r1.ebuild b/dev-python/python-ptrace/python-ptrace-0.8.1-r1.ebuild
deleted file mode 100644
index e06a9ef4932c..000000000000
--- a/dev-python/python-ptrace/python-ptrace-0.8.1-r1.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_{5,6}} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="A debugger using ptrace (Linux, BSD and Darwin system call to trace processes)"
-HOMEPAGE="https://github.com/haypo/python-ptrace/ https://pypi.org/project/python-ptrace/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc examples"
-
-PATCHES=( "${FILESDIR}/0.8.1-python3.4.patch" )
-
-python_test() {
- "${PYTHON}" runtests.py -v || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( examples/. )
- # doc folder missing key files to effect a proper doc build
- use doc && local DOCS=( README doc/. )
- distutils-r1_python_install_all
-}