summaryrefslogtreecommitdiff
path: root/dev-python/python-ntpdshm
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-ntpdshm')
-rw-r--r--dev-python/python-ntpdshm/Manifest2
-rw-r--r--dev-python/python-ntpdshm/python-ntpdshm-0.2.1.ebuild12
2 files changed, 6 insertions, 8 deletions
diff --git a/dev-python/python-ntpdshm/Manifest b/dev-python/python-ntpdshm/Manifest
index ccd57b93d296..e373f9ec1238 100644
--- a/dev-python/python-ntpdshm/Manifest
+++ b/dev-python/python-ntpdshm/Manifest
@@ -1,3 +1,3 @@
DIST python-ntpdshm-0.2.1.tar.gz 12227 BLAKE2B 612debd1a9a1809298a690068e3872f727fa9d58496e62530ab236a9f80e020770d54f7a6b3caf797f33f22cb0b75597d79a2ed578e24b11dea787cca2c3c667 SHA512 1c03f38d3f17e3871ced238e6654c57704b3dd4ab49b8cebf1eb4af3a4263de2fb3769933ccf9ebbf2ce5ca5a0ec8875a10ca07161a7e554d6d1ce93e4a2ed4c
-EBUILD python-ntpdshm-0.2.1.ebuild 688 BLAKE2B 64d80a2e753c0adbdfde138820ca080ad60613fda0ea4c152bf23f3587aad14fb0b24d224e33568dcc42c3056364188df0e5edfa90514e4318d0720dc3a5cfc2 SHA512 7e0937db3b14111f6f452f243ccd8497007ad0c0c74163e4d1720b87ebb62e05494d1392cdabbc22770394150e08788c2c80c60faf60d040aeabbcee45f8d197
+EBUILD python-ntpdshm-0.2.1.ebuild 695 BLAKE2B b567d348ca27fe7585b2aea56cc22136f708b825ee80f42002bf33c546306cf9d0520aff34a7fb4f4998e7ad5c9949ac50319dd190b7d473e5d0f7fcfa8100b8 SHA512 012a7bffdb56741ead52bd7ad61073ab225704cea65e4ac697abc060774398e563158875f31528f9733d4efd0c081ee0e8f58537847520d561b64431407f7b7c
MISC metadata.xml 288 BLAKE2B cf804565346328dfd23bbc04533dc8844d4a5e3debf432bacc1545780a249cc3a363efae85f6577c04bed761dbfd8f0259c3aaf05b2505528666bc6d83d4fbda SHA512 a0f7d154b6b1b48e88243ef1ede582c3cbb9056d73bc9003e4f8add773306f48c9b75f103ed85a1a18e870c31ef5eb0ec19f44a814261b3c866cdb756c2a75f5
diff --git a/dev-python/python-ntpdshm/python-ntpdshm-0.2.1.ebuild b/dev-python/python-ntpdshm/python-ntpdshm-0.2.1.ebuild
index 6f3c061f3c0b..434158ae2650 100644
--- a/dev-python/python-ntpdshm/python-ntpdshm-0.2.1.ebuild
+++ b/dev-python/python-ntpdshm/python-ntpdshm-0.2.1.ebuild
@@ -1,21 +1,22 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{5,6}} pypy )
+PYTHON_COMPAT=( python3_6 )
inherit distutils-r1
DESCRIPTION="Python interface to ntpd shared memory driver 28"
HOMEPAGE="https://github.com/mjuenema/python-ntpdshm"
-SRC_URI="${HOMEPAGE}/archive/0.2.1.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/mjuenema/python-ntpdshm/archive/${PV}.tar.gz -> ${P}.tar.gz"
# Warning: pypi tarball is not the same
#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+# tests may break running ntpd!
+RESTRICT="test"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
@@ -25,6 +26,3 @@ src_prepare() {
emake swig
distutils-r1_src_prepare
}
-
-# tests may break running ntpd!
-RESTRICT="test"