summaryrefslogtreecommitdiff
path: root/dev-python/python-lsp-server
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-lsp-server')
-rw-r--r--dev-python/python-lsp-server/Manifest2
-rw-r--r--dev-python/python-lsp-server/files/python-lsp-server-1.4.1-allow-mccabe-0.7.patch22
-rw-r--r--dev-python/python-lsp-server/python-lsp-server-1.4.1-r1.ebuild90
3 files changed, 114 insertions, 0 deletions
diff --git a/dev-python/python-lsp-server/Manifest b/dev-python/python-lsp-server/Manifest
index 18aeb22f4800..beec64cb1526 100644
--- a/dev-python/python-lsp-server/Manifest
+++ b/dev-python/python-lsp-server/Manifest
@@ -1,3 +1,5 @@
+AUX python-lsp-server-1.4.1-allow-mccabe-0.7.patch 625 BLAKE2B 60880a45b859273e9ac3078210b4a1deffd2d6b88ef0fc7a4bbfb6beefe50291c777e6c1681ebb333b1b302ce3df38e8d21aef844b49d7dc0e3cf0d5bdc76229 SHA512 100728b441d48301d8516ba5ce5396a70c9f30f8c02b8b2eebdd3f9248e534c96c1845f8e327c2f31529756bcb9a411a56c845ff8a802f6cc4ad694b71c48b76
DIST python-lsp-server-1.4.1.tar.gz 76416 BLAKE2B 65638b876182c478434c563371b802367fb8439820ccf57e4404dc1507f3cd514ae5d738d418386607db606025fe5126a533c656ec3fede53fdcfd364a4292cf SHA512 4c9171adc88d219c80055ebbc76566583925129969467c156277b52de9b5981b74b11b9961247045ea98cd9e51e146b2d606c8351a7be5db76f6f4e0e4d7195c
+EBUILD python-lsp-server-1.4.1-r1.ebuild 3086 BLAKE2B 7b2f1851b082ae6ac5ec8353a1e8d155060197602c4ddb68a1d7487590313dd08ebdbde64d78ea0cada6fd309945824621d45206047fa8e16c290fd90c23c973 SHA512 17b3cf9fa4de342e3455d65f76aae4c1c0c1bcad73fd142974249aa09b08edaa32200650ac89761c42be7ce4722534b47c4913b7727c93443ab584775a64f467
EBUILD python-lsp-server-1.4.1.ebuild 3022 BLAKE2B 70afa37aa74104074f3571023bd958258a71772ec4de133fa74894764e3113ef78f9601a05be6dfa1e32bd08b9e43d9b188c56d09c9f765a303d0d4aed615cff SHA512 1394fca67580bc6d2af26444a14ff642257ee7aa394f9866f69f092d3624eb7c5f0fa46d56f2d90068ddf90006d6fb9a62c51c0dfd8162d4b77664242829dae1
MISC metadata.xml 542 BLAKE2B ca71a08385d37c7f5cc562986630ae482970842054ffa944151d2e4a5d8449329b71c16c61e2a81f3d3d93f02a61ce637fe0bd0961ba3f86b7182b9728b62d5c SHA512 2d5103643838ba8aec53e7d3e924517cc3d735c724b6dfea249bcce3716aebb9f54e3264cb2cccc15dfe7d0ad4b7d052388122144fe6248d4faeef3482d197e7
diff --git a/dev-python/python-lsp-server/files/python-lsp-server-1.4.1-allow-mccabe-0.7.patch b/dev-python/python-lsp-server/files/python-lsp-server-1.4.1-allow-mccabe-0.7.patch
new file mode 100644
index 000000000000..a31201ab6b15
--- /dev/null
+++ b/dev-python/python-lsp-server/files/python-lsp-server-1.4.1-allow-mccabe-0.7.patch
@@ -0,0 +1,22 @@
+diff --git a/setup.cfg b/setup.cfg
+index 156145f..c46fcf3 100644
+--- a/setup.cfg
++++ b/setup.cfg
+@@ -26,7 +26,7 @@ exclude = contrib; docs; test; test.*; test.plugins; test.plugins.*
+ all =
+ autopep8>=1.6.0,<1.7.0
+ flake8>=4.0.0,<4.1.0
+- mccabe>=0.6.0,<0.7.0
++ mccabe>=0.6.0,<0.8.0
+ pycodestyle>=2.8.0,<2.9.0
+ pydocstyle>=2.0.0
+ pyflakes>=2.4.0,<2.5.0
+@@ -35,7 +35,7 @@ all =
+ yapf
+ autopep8 = autopep8>=1.6.0,<1.7.0
+ flake8 = flake8>=4.0.0,<4.1.0
+-mccabe = mccabe>=0.6.0,<0.7.0
++mccabe = mccabe>=0.6.0,<0.8.0
+ pycodestyle = pycodestyle>=2.8.0,<2.9.0
+ pydocstyle = pydocstyle>=2.0.0
+ pyflakes = pyflakes>=2.4.0,<2.5.0
diff --git a/dev-python/python-lsp-server/python-lsp-server-1.4.1-r1.ebuild b/dev-python/python-lsp-server/python-lsp-server-1.4.1-r1.ebuild
new file mode 100644
index 000000000000..5b50d2c382e3
--- /dev/null
+++ b/dev-python/python-lsp-server/python-lsp-server-1.4.1-r1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python Language Server for the Language Server Protocol"
+HOMEPAGE="https://github.com/python-lsp/python-lsp-server"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+
+IUSE="all-plugins"
+
+BDEPEND="
+ test? (
+ >=dev-python/autopep8-1.6.0[${PYTHON_USEDEP}]
+ <dev-python/autopep8-1.7.0[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ >=dev-python/flake8-4.0.0[${PYTHON_USEDEP}]
+ <dev-python/flake8-4.1.0[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.6.0[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.8.0[${PYTHON_USEDEP}]
+ <dev-python/numpy-1.23.0[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.8.0[${PYTHON_USEDEP}]
+ <dev-python/pycodestyle-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/pydocstyle-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyflakes-2.4.0[${PYTHON_USEDEP}]
+ <dev-python/pyflakes-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/pylint-2.5.0[${PYTHON_USEDEP}]
+ dev-python/QtPy[gui,testlib,${PYTHON_USEDEP}]
+ >=dev-python/rope-0.10.5[${PYTHON_USEDEP}]
+ dev-python/yapf[${PYTHON_USEDEP}]
+ )
+"
+
+RDEPEND="
+ >=dev-python/jedi-0.17.2[${PYTHON_USEDEP}]
+ <dev-python/jedi-0.19.0[${PYTHON_USEDEP}]
+ >=dev-python/python-lsp-jsonrpc-1.0.0[${PYTHON_USEDEP}]
+ dev-python/pluggy[${PYTHON_USEDEP}]
+ all-plugins? (
+ >=dev-python/autopep8-1.6.0[${PYTHON_USEDEP}]
+ <dev-python/autopep8-1.7.0[${PYTHON_USEDEP}]
+ >=dev-python/flake8-4.0.0[${PYTHON_USEDEP}]
+ <dev-python/flake8-4.1.0[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.6.0[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.8.0[${PYTHON_USEDEP}]
+ <dev-python/pycodestyle-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/pydocstyle-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyflakes-2.4.0[${PYTHON_USEDEP}]
+ <dev-python/pyflakes-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/pylint-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/rope-0.10.5[${PYTHON_USEDEP}]
+ dev-python/yapf[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-allow-mccabe-0.7.patch"
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # remove pytest-cov dep
+ sed -i -e '0,/addopts/I!d' setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+pkg_postinst() {
+ optfeature "Automatically format Python code to conform to the PEP 8 style guide" dev-python/autopep8
+ optfeature "A wrapper around PyFlakes, pep8 & mccabe" dev-python/flake8
+ optfeature "flake8 plugin: McCabe complexity checker" dev-python/mccabe
+ optfeature "Python style guide checker (fka pep8)" dev-python/pycodestyle
+ optfeature "Python docstring style checker" dev-python/pydocstyle
+ optfeature "Passive checker for Python programs" dev-python/pyflakes
+ optfeature "Python code static checker" dev-python/pylint
+ optfeature "Python refactoring library" dev-python/rope
+ optfeature "A formatter for Python files" dev-python/yapf
+}