summaryrefslogtreecommitdiff
path: root/dev-python/python-linux-procfs/python-linux-procfs-0.6.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-linux-procfs/python-linux-procfs-0.6.1.ebuild')
-rw-r--r--dev-python/python-linux-procfs/python-linux-procfs-0.6.1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/python-linux-procfs/python-linux-procfs-0.6.1.ebuild b/dev-python/python-linux-procfs/python-linux-procfs-0.6.1.ebuild
new file mode 100644
index 000000000000..d26695838457
--- /dev/null
+++ b/dev-python/python-linux-procfs/python-linux-procfs-0.6.1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python classes to extract information from the Linux kernel /proc files"
+HOMEPAGE="https://www.kernel.org/pub/scm/libs/python/python-linux-procfs/
+ https://kernel.googlesource.com/pub/scm/libs/python/python-linux-procfs/python-linux-procfs/"
+SRC_URI="https://cdn.kernel.org/pub/software/libs/python/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"