summaryrefslogtreecommitdiff
path: root/dev-python/python-libevdev/python-libevdev-0.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-libevdev/python-libevdev-0.9.ebuild')
-rw-r--r--dev-python/python-libevdev/python-libevdev-0.9.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/python-libevdev/python-libevdev-0.9.ebuild b/dev-python/python-libevdev/python-libevdev-0.9.ebuild
new file mode 100644
index 000000000000..a8f0ef742a66
--- /dev/null
+++ b/dev-python/python-libevdev/python-libevdev-0.9.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrappers for the libevdev library"
+HOMEPAGE="https://gitlab.freedesktop.org/libevdev/python-libevdev"
+SRC_URI="https://gitlab.freedesktop.org/libevdev/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? ( dev-libs/libevdev )
+"
+
+python_test() {
+ esetup.py test
+}