summaryrefslogtreecommitdiff
path: root/dev-python/python-glanceclient
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-glanceclient')
-rw-r--r--dev-python/python-glanceclient/Manifest2
-rw-r--r--dev-python/python-glanceclient/python-glanceclient-3.5.0.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/python-glanceclient/Manifest b/dev-python/python-glanceclient/Manifest
index 4ffe5d3a59a9..baafe38b1a6d 100644
--- a/dev-python/python-glanceclient/Manifest
+++ b/dev-python/python-glanceclient/Manifest
@@ -1,3 +1,5 @@
DIST python-glanceclient-3.2.2.tar.gz 191501 BLAKE2B 0ccafb81aa01f35313a6d312496538b0a3c7f2b8df9f0523b244fdcaf55eedb48a7b9beb750b56df2303bf0e4f32e6cd85bdb998618584bae05f36db606b0eed SHA512 900c8120f2a06f2bf5016ea22883b78926c5b8b27782692f3e44a473985e31cd8c6285371ef16f61dfac79828add8d841363f043453cd68ca6ddb31c8c126606
+DIST python-glanceclient-3.5.0.tar.gz 198273 BLAKE2B 7861a2124a9474c4f6267f5b82e6d7fa9825d3cdc8411fbb05afabf69928dd230a881452de57cf54f9cd1a52157f806826036d85f6a93651980ce65e86afd520 SHA512 e5db1afeea7e3f653d7afac7961aeb3ec28df5dc40bba6b8b70795efcfc66928c2af45ecc0e4bbcc0d59a0157599e4ef3af090a8b0ccd0d727e8a94d4f8c866e
EBUILD python-glanceclient-3.2.2-r1.ebuild 1390 BLAKE2B 311a5f52816ee70aba0dcb7da63a2a75db7659c2e9d8e3239c4926791c119f6b847f00b130dac007ac693ed0634b6372811587f27afd5b874d6c83b347316077 SHA512 d8f35a50158a4eb2536f83fa43fde8b238c02559d4245ac836f86360081239c1d7ea82d0095bcdc5fb1977a4e213cd40ca88d3ec06e8a5c7b4450863bee49b33
+EBUILD python-glanceclient-3.5.0.ebuild 1323 BLAKE2B f9753d277ea2cb034d3c609ec1f63c744438b890d76999ede99aaff59b6d0333841833dab734020ec8a98d86a9f57d8cca175af7aadf3f7da45a81eafa04a377 SHA512 3f421f833ee6fb7489cdd648e79d6f7ae49aceb0ae98e4d7586456d47e08fbe7d0b90b17e5a3126da423d7c7a06487641f3fd8421f4a9d409774b7b962f20e2b
MISC metadata.xml 556 BLAKE2B 1007f5d86b8a7a5feb6018997ad5126f31c10d619d480adaf28db855ae9745c1395632b1d0fb9c915106e7678b7148487c3a2de800e8bf19e1abe55b00df7ecd SHA512 43aa944c6c8a91dfe59aa8261718fe144c852f0e036cddbf4453cfcfde21816e619388de98713de965d03c63ae242ee4fc27be103263cd1d44a5985b3c905fd0
diff --git a/dev-python/python-glanceclient/python-glanceclient-3.5.0.ebuild b/dev-python/python-glanceclient/python-glanceclient-3.5.0.ebuild
new file mode 100644
index 000000000000..05b52a6f08b4
--- /dev/null
+++ b/dev-python/python-glanceclient/python-glanceclient-3.5.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Glance API"
+HOMEPAGE="https://github.com/openstack/python-glanceclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="
+ >=dev-python/keystoneauth-3.6.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-17.1.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/warlock-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/warlock-2[${PYTHON_USEDEP}]
+ >=dev-python/wrapt-1.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ddt[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/tempest[${PYTHON_USEDEP}]
+ dev-python/testscenarios[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ # functional tests require cloud instance access
+ eunittest -b glanceclient/tests/unit
+}