summaryrefslogtreecommitdiff
path: root/dev-python/python-engineio/python-engineio-4.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-engineio/python-engineio-4.2.1.ebuild')
-rw-r--r--dev-python/python-engineio/python-engineio-4.2.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/python-engineio/python-engineio-4.2.1.ebuild b/dev-python/python-engineio/python-engineio-4.2.1.ebuild
new file mode 100644
index 000000000000..3fba6ef7d60a
--- /dev/null
+++ b/dev-python/python-engineio/python-engineio-4.2.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the Engine.IO realtime server."
+HOMEPAGE="
+ https://python-engineio.readthedocs.io/
+ https://github.com/miguelgrinberg/python-engineio/
+ https://pypi.org/project/python-engineio/"
+SRC_URI="
+ https://github.com/miguelgrinberg/python-engineio/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/eventlet[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest