summaryrefslogtreecommitdiff
path: root/dev-python/python-dbusmock
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-dbusmock')
-rw-r--r--dev-python/python-dbusmock/Manifest2
-rw-r--r--dev-python/python-dbusmock/python-dbusmock-0.32.2.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/python-dbusmock/Manifest b/dev-python/python-dbusmock/Manifest
index 384b2af57991..160757c475fd 100644
--- a/dev-python/python-dbusmock/Manifest
+++ b/dev-python/python-dbusmock/Manifest
@@ -1,3 +1,5 @@
DIST python-dbusmock-0.32.1.tar.gz 104265 BLAKE2B 78357a767e8f008463c69b55b57a02016c1aa1a392dc7a1ef3392020af839ef553ed6ff3cadac12a9c175efccdb29c7f3ed74ab7abafb0436a760dbe3193fbc6 SHA512 14b71c5d0a760fd1e8609815e4ae702ebc5c9f1f3c3e1bd930da616350b63b7fdbf99c7d584f5a834857798fb1cad56347d6a1cf2bdd758f9100180b0a7e725d
+DIST python-dbusmock-0.32.2.tar.gz 104818 BLAKE2B c0859d38efe9e78f465c5e69980ada2a0309fc654a4a77f213b23e4140d7fad60f497d9a0004c61db1870eaeb3700a5ee46ce2f14b4e570cb3c74ede99c24980 SHA512 09981dddd49e430093996de78d96293c46867fad7ab24e1badde25cda5f60b05324bd203d5738e8f4315c5744809876ac4afd73aa26bcc6afa05fd631c03ceba
EBUILD python-dbusmock-0.32.1.ebuild 1189 BLAKE2B 238d3ccb1863e3e4186186ec80101dbf448c8aea0ee8f90754ea544bdc808bfe1d5708ec4688621ce4c8768b4d42d1c66e6009fa263d3d8c1d1e1d12a456c1d4 SHA512 325dfdd5664e66df2be0df113fc933869c1f50129fcfb9a0e203c01cd013bf3b83227341321c0eea5d88cb21095c73d463e4a04bb2f4444dcec967112da4e05f
+EBUILD python-dbusmock-0.32.2.ebuild 1196 BLAKE2B 4d800494343afc9480579de5379f274ed46c0c44f227a41dbf97d0600a9056023f51afb7ccf284779f9d18e776ce1f3b6f4c21d7e3282ae1b2d073569f1ec82c SHA512 20587a6c0bff7a447fdbcae3be93358f973bbd8e52433e3a30848345e3c1597edadb40142d06a768a5f114364a27b6a4d16c925e413ee5d737fea5d2b7008f18
MISC metadata.xml 523 BLAKE2B 85fe2f51626a9c5de1376ebb88d908ea3c0a4e47d940f4a6730c72762f8e457b056a2ef080da519fec5ec15338eb2eb0d590cf5f20a7f711e40e7c97def84c51 SHA512 6718af48a4b968687e8eb1ddfefc1e21d4fda774d3e3d94e198c77c745761d3ab13e1bb4c34b65e6dff11c9a1b5f6018d53b113967784445bea71788fb3344b1
diff --git a/dev-python/python-dbusmock/python-dbusmock-0.32.2.ebuild b/dev-python/python-dbusmock/python-dbusmock-0.32.2.ebuild
new file mode 100644
index 000000000000..eafbf2454b72
--- /dev/null
+++ b/dev-python/python-dbusmock/python-dbusmock-0.32.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..13} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Easily create mock objects on D-Bus for software testing"
+HOMEPAGE="
+ https://github.com/martinpitt/python-dbusmock/
+ https://pypi.org/project/python-dbusmock/
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ sys-power/upower
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # linter tests, fragile to newer linter versions
+ tests/test_code.py
+)
+
+src_prepare() {
+ # dev-python/dbus-python uses autotools, so no .dist-info there
+ sed -i '/dbus-python/d' pyproject.toml setup.cfg || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # tests are fragile to long socket paths
+ local -x TMPDIR=/tmp
+ # Tests break if XDG_DATA_DIRS is modified by flatpak install
+ unset XDG_DATA_DIRS
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}