summaryrefslogtreecommitdiff
path: root/dev-python/python-dbusmock
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-dbusmock')
-rw-r--r--dev-python/python-dbusmock/Manifest2
-rw-r--r--dev-python/python-dbusmock/python-dbusmock-0.34.3.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/python-dbusmock/Manifest b/dev-python/python-dbusmock/Manifest
index 2d745a9a4e74..ff6a34daeac3 100644
--- a/dev-python/python-dbusmock/Manifest
+++ b/dev-python/python-dbusmock/Manifest
@@ -1,3 +1,5 @@
DIST python_dbusmock-0.34.2.tar.gz 111535 BLAKE2B 8f3f125bcfbf0d1674e0dea3d87d6f776e85fb818c5fd3f814ca139f4f6936e06eabe7c60c467114918609e1897b0c770a5765eb356fc1843eb781e264fd93ac SHA512 3a4a46afa0ca54004a6891c639c0e1bfd879e575189bdd1bbe031f12333d2358af77456e8b6cb32681010b7c19fb8171f819f67ec8960494408100118b19881d
+DIST python_dbusmock-0.34.3.tar.gz 111656 BLAKE2B 5ec1ed245f5ac3bb68464a18b6bdbb45781c17ea500068d5dc26132cd30712731ef9a33a8ab9e6c17af1d21dc879f5913b9251a9d3ca6fe2a737af7c2f6752f2 SHA512 96b5ef9b0c41afaa703b608bbc1ec27704359a61b83d633bd10718a314f84b91208961e9e4b5d96718a2ac70b5b96b0e00039b7d6bfd4436470dafd34d28f0e4
EBUILD python-dbusmock-0.34.2.ebuild 1169 BLAKE2B bd5e24651e0e15b2f4661390216f08c057f75566bd32e846aa8b0d8e9c05024963700361c369f7f09c9e1dd8f68b0d3c12defcc64afd848fb121e11a50fc0168 SHA512 9ed315dbe186cc2fd0499dcc8ce0024fd40b2788ce44316fba4c496f232b765902f6519dd6777fb12d7274946f79ba4dfd78310c6117269460e904feb18d48dc
+EBUILD python-dbusmock-0.34.3.ebuild 1176 BLAKE2B 5430bb8804ff48026a7a2752d211336eba943ce4be656b19cc699e7756e8783c700a16b7ce77797b2fc60056549d183705e23f92432c93cb3183a4998bc24227 SHA512 2f0b9c30d99d99efe96c0c86e426bab61e50010c4531e0b2aede5d938730f9b1edbe6e1fe31d773853b16881b315c57e0f7842be33e87330567fc5eed4aca01c
MISC metadata.xml 523 BLAKE2B 85fe2f51626a9c5de1376ebb88d908ea3c0a4e47d940f4a6730c72762f8e457b056a2ef080da519fec5ec15338eb2eb0d590cf5f20a7f711e40e7c97def84c51 SHA512 6718af48a4b968687e8eb1ddfefc1e21d4fda774d3e3d94e198c77c745761d3ab13e1bb4c34b65e6dff11c9a1b5f6018d53b113967784445bea71788fb3344b1
diff --git a/dev-python/python-dbusmock/python-dbusmock-0.34.3.ebuild b/dev-python/python-dbusmock/python-dbusmock-0.34.3.ebuild
new file mode 100644
index 000000000000..756162b12928
--- /dev/null
+++ b/dev-python/python-dbusmock/python-dbusmock-0.34.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Easily create mock objects on D-Bus for software testing"
+HOMEPAGE="
+ https://github.com/martinpitt/python-dbusmock/
+ https://pypi.org/project/python-dbusmock/
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ sys-power/upower
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # linter tests, fragile to newer linter versions
+ tests/test_code.py
+)
+
+src_prepare() {
+ # dev-python/dbus-python uses autotools, so no .dist-info there
+ sed -i '/dbus-python/d' pyproject.toml setup.cfg || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # tests are fragile to long socket paths
+ local -x TMPDIR=/tmp
+ # Tests break if XDG_DATA_DIRS is modified by flatpak install
+ unset XDG_DATA_DIRS
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}