summaryrefslogtreecommitdiff
path: root/dev-python/python-dbusmock
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-dbusmock')
-rw-r--r--dev-python/python-dbusmock/Manifest2
-rw-r--r--dev-python/python-dbusmock/python-dbusmock-0.24.0.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/python-dbusmock/Manifest b/dev-python/python-dbusmock/Manifest
index c01b26677adf..19fb37531ad3 100644
--- a/dev-python/python-dbusmock/Manifest
+++ b/dev-python/python-dbusmock/Manifest
@@ -1,3 +1,5 @@
DIST python-dbusmock-0.23.1.tar.gz 79964 BLAKE2B 60140997f7a9c196d4c38100a975550d6a4745344fde9084ca5a56881035c09cfd56387897a7e409e35aecbc759f01b8f4953b8a5cdda4bfbe70d80cd01b8332 SHA512 933205c770f82aef623e571d9d806b6d639467c977ca326718ff475f41e309ef25e9a8f1cd8439e181edbafeb6513af7b73dfb938b3abfc7d5f63b6b5ffa9fc9
+DIST python-dbusmock-0.24.0.tar.gz 81907 BLAKE2B 5fc8653228d9278c74e623d385c798ba078da5d8309a95e88a893d3ceb1736568f93196defcde1845bfee193ec2e7abb4197a663f612dfe4ff58ac9c0bb189e3 SHA512 531c2d427da28098d7dac91cd5be1c38be15dfc9495314a150523e56c10ffda846667dfda39cc47c8278ad41800fe39d6608f24da44ff2ae7d53f0413826d96c
EBUILD python-dbusmock-0.23.1.ebuild 833 BLAKE2B 72f56445e7f261c2bec3edd777c9a5469ea8f77e509be07539a3fb9e31ffd0e501a7e4204451cc8f0d0e9401434129d68789c516e4d9b109e6d5b77f0ad04961 SHA512 25370c4a184a0828e4e02f900cc9a00798d0602f8759f18f276e0939d6cd2f4b287e136233da2b05f2af4f4953f3faa10d6d4ddc73ca16bb29f28125878d0b0e
+EBUILD python-dbusmock-0.24.0.ebuild 840 BLAKE2B 2e3a185989812753a4a232f4158d02baa6344d5b9d0848a4532963b84869e3998b18e2b3b51a30ca41fe367268d6e2fab7036e8d1a74daba4ca33870f8c58bae SHA512 6ff827cf08f2f67b0026ed2cc89172fc50a38ce141b751d4e9dae552f8dd580c50bc4ba7e767440080c8d61ec20489302e2b1c79ab14d03a608bb05f31a0c244
MISC metadata.xml 456 BLAKE2B 1255b5eaa7068525c5661663a3d42b052100e7c0c9ad58f4b85ba6113d2b0ebd4a48691ca52bbaf10635d34e5fe8949b6e44f98babe514ca78663462fa88a85c SHA512 ce665cd1934e2307281538e1f306297974cdf50c7c5576ebd2f290066a39b1a18bd1dfbe34bef29d5f332847699699b811754bac9d52364a96c66b030d953362
diff --git a/dev-python/python-dbusmock/python-dbusmock-0.24.0.ebuild b/dev-python/python-dbusmock/python-dbusmock-0.24.0.ebuild
new file mode 100644
index 000000000000..aa54623eb206
--- /dev/null
+++ b/dev-python/python-dbusmock/python-dbusmock-0.24.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Easily create mock objects on D-Bus for software testing"
+HOMEPAGE="https://github.com/martinpitt/python-dbusmock"
+SRC_URI="
+ https://github.com/martinpitt/python-dbusmock/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # needed for unittest discovery
+ > tests/__init__.py || die
+ # linter tests, fragile to newer linter versions
+ rm tests/test_code.py || die
+
+ distutils-r1_src_prepare
+}