summaryrefslogtreecommitdiff
path: root/dev-python/python-dbusmock/python-dbusmock-0.23.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-dbusmock/python-dbusmock-0.23.1.ebuild')
-rw-r--r--dev-python/python-dbusmock/python-dbusmock-0.23.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/python-dbusmock/python-dbusmock-0.23.1.ebuild b/dev-python/python-dbusmock/python-dbusmock-0.23.1.ebuild
new file mode 100644
index 000000000000..082b1a20d912
--- /dev/null
+++ b/dev-python/python-dbusmock/python-dbusmock-0.23.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Easily create mock objects on D-Bus for software testing"
+HOMEPAGE="https://github.com/martinpitt/python-dbusmock"
+SRC_URI="
+ https://github.com/martinpitt/python-dbusmock/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv sparc x86"
+
+RDEPEND="
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # needed for unittest discovery
+ > tests/__init__.py || die
+ # linter tests, fragile to newer linter versions
+ rm tests/test_code.py || die
+
+ distutils-r1_src_prepare
+}