summaryrefslogtreecommitdiff
path: root/dev-python/python-cstruct
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-cstruct')
-rw-r--r--dev-python/python-cstruct/Manifest2
-rw-r--r--dev-python/python-cstruct/python-cstruct-5.2.ebuild27
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/python-cstruct/Manifest b/dev-python/python-cstruct/Manifest
index 79c23de184b5..b64c84ff676e 100644
--- a/dev-python/python-cstruct/Manifest
+++ b/dev-python/python-cstruct/Manifest
@@ -1,5 +1,7 @@
DIST python-cstruct-5.0.gh.tar.gz 36194 BLAKE2B 436998e52f2cfa714eb49c606a76b2ae72af959c58addbd2cff036a3ecd6bfea22e43da2c6c17a2d4c1328578385ecd8605afbc3dcdcb4e083125588a6020751 SHA512 f28977ae0b4db9bed0b5757f257b772089dd37844cb47455be3c406f5e5245194f98eae98520ad9888306e31a581617229b8634d0e5881c38c0e8deb84bc5ef8
DIST python-cstruct-5.1.gh.tar.gz 37905 BLAKE2B 0559e09ed16cb171e6fa5ab6e92150c986579b25b19cce4b3e0e23e0969bb02a5598a25b8f3b412aae04c4522dc25b66a9d9d310a661ca4657896d9e16811c81 SHA512 28a0221b63074a83704c0bade58b7a0d195ec56057bdee9b6e4c15c76619ee20854155ff7a4910909c0e82ad81c92c01c67ffc6e1eb2b8d702911ad8a1392dd0
+DIST python-cstruct-5.2.gh.tar.gz 38551 BLAKE2B d366c7508c33f7dd492cb3a507a358129159634b9f32293c4a06a8c1a24e9d4ae5e6a1fd89144907497e17b2558277fe98d4a5d92313402304bb18bec5c395ea SHA512 d9a961270e4769d1133a459f952f22b42733421436c53ac9bfc8159330503af1a2231c99afb2e91863ee8ad4d822a0d84fc6db6aac11b5358bca5548f0006e3e
EBUILD python-cstruct-5.0.ebuild 641 BLAKE2B 9032b93fe2debf296696527a3ea750e60d0864e818756b243606ed29c8304661c81ddb6b2953c3434ae109971b3cfd9c13fa13f41dac69c4aa9a15c5b0cb0d2c SHA512 429e2ed7737ed3cde9fb9d1b287d5e5d09ffaf7b95ca5a83c0d947254e6d62447523fa95e29f176ef873ce72ee3eba59b5f23a6c3fd9a9f8564ab24a5ba5900c
EBUILD python-cstruct-5.1.ebuild 525 BLAKE2B 49c867fb2be51fd8f9c7bb2eb323222d2d32b331662c820c2993299c8549a699c6db261684ca0290f0a7719d0685b8d3a828e614cccbe11bc69aac2c6acf16fb SHA512 cec3cddf6aa7f52288526f39a0ea6f41870ad544a95324aa0808474a0b932cc98d1c7f7076a8a13b354fea83d3e4f34c0d3d59229e6211b5e3b2504ccd7fdbcc
+EBUILD python-cstruct-5.2.ebuild 525 BLAKE2B 49c867fb2be51fd8f9c7bb2eb323222d2d32b331662c820c2993299c8549a699c6db261684ca0290f0a7719d0685b8d3a828e614cccbe11bc69aac2c6acf16fb SHA512 cec3cddf6aa7f52288526f39a0ea6f41870ad544a95324aa0808474a0b932cc98d1c7f7076a8a13b354fea83d3e4f34c0d3d59229e6211b5e3b2504ccd7fdbcc
MISC metadata.xml 454 BLAKE2B 5138bc275b0b9e18cab52fb309283c6b6dab8be5dcc3c86dd6526f350b216c68bc94dd2aabc7a33a4879c23165924563396c6d5991f5c702a12e184067d25cdb SHA512 bb259a25444029d8ea63577f0576ab283282298d27987e276bf4eb6d4ef00853ed019ad199830e9bb4e738f9a151feb55d53e76917508f1033c2b3ecd246276f
diff --git a/dev-python/python-cstruct/python-cstruct-5.2.ebuild b/dev-python/python-cstruct/python-cstruct-5.2.ebuild
new file mode 100644
index 000000000000..e1a88b9460d4
--- /dev/null
+++ b/dev-python/python-cstruct/python-cstruct-5.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="C-style structs for Python"
+HOMEPAGE="
+ https://github.com/andreax79/python-cstruct/
+ https://pypi.org/project/cstruct/
+"
+SRC_URI="
+ https://github.com/andreax79/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+
+distutils_enable_tests pytest