summaryrefslogtreecommitdiff
path: root/dev-python/python-consul/python-consul-1.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-consul/python-consul-1.1.0.ebuild')
-rw-r--r--dev-python/python-consul/python-consul-1.1.0.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-python/python-consul/python-consul-1.1.0.ebuild b/dev-python/python-consul/python-consul-1.1.0.ebuild
deleted file mode 100644
index 414d22a70c4d..000000000000
--- a/dev-python/python-consul/python-consul-1.1.0.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_5 python3_6 )
-inherit distutils-r1
-
-DESCRIPTION="Python client for Consul"
-HOMEPAGE="https://github.com/cablehead/python-consul/"
-SRC_URI="https://github.com/cablehead/python-consul/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND="dev-python/aiohttp[${PYTHON_USEDEP}]
- >=dev-python/requests-2.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.4[${PYTHON_USEDEP}]
- dev-python/twisted[${PYTHON_USEDEP}]
- >=dev-python/treq-16[${PYTHON_USEDEP}]
- www-servers/tornado[${PYTHON_USEDEP}]"
-DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}]
- ${RDEPEND} )"
-
-# needs pytest-twisted
-RESTRICT="test"
-
-python_test() {
- py.test -v || die
-}