summaryrefslogtreecommitdiff
path: root/dev-python/python-bugzilla/python-bugzilla-3.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-bugzilla/python-bugzilla-3.1.0.ebuild')
-rw-r--r--dev-python/python-bugzilla/python-bugzilla-3.1.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/python-bugzilla/python-bugzilla-3.1.0.ebuild b/dev-python/python-bugzilla/python-bugzilla-3.1.0.ebuild
new file mode 100644
index 000000000000..137bbf61ee25
--- /dev/null
+++ b/dev-python/python-bugzilla/python-bugzilla-3.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A python module for interacting with Bugzilla over XMLRPC"
+HOMEPAGE="https://github.com/python-bugzilla/python-bugzilla"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+
+RDEPEND="
+ || (
+ dev-python/python-magic[${PYTHON_USEDEP}]
+ sys-apps/file[python,${PYTHON_USEDEP}]
+ )
+ dev-python/requests[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest