summaryrefslogtreecommitdiff
path: root/dev-python/python-barbicanclient/python-barbicanclient-4.6.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-barbicanclient/python-barbicanclient-4.6.0.ebuild')
-rw-r--r--dev-python/python-barbicanclient/python-barbicanclient-4.6.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/python-barbicanclient/python-barbicanclient-4.6.0.ebuild b/dev-python/python-barbicanclient/python-barbicanclient-4.6.0.ebuild
new file mode 100644
index 000000000000..ec9748eaaf8e
--- /dev/null
+++ b/dev-python/python-barbicanclient/python-barbicanclient-4.6.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Client library for Barbican API."
+HOMEPAGE="https://github.com/openstack/barbican"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/cliff-2.8.0[${PYTHON_USEDEP}]
+ !~dev-python/cliff-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.3.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.18.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-serialization-1.19.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+"