summaryrefslogtreecommitdiff
path: root/dev-python/pytest-xvfb
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-xvfb')
-rw-r--r--dev-python/pytest-xvfb/Manifest2
-rw-r--r--dev-python/pytest-xvfb/pytest-xvfb-3.0.0.ebuild11
2 files changed, 5 insertions, 8 deletions
diff --git a/dev-python/pytest-xvfb/Manifest b/dev-python/pytest-xvfb/Manifest
index d458880914a0..d2a7bc282080 100644
--- a/dev-python/pytest-xvfb/Manifest
+++ b/dev-python/pytest-xvfb/Manifest
@@ -1,3 +1,3 @@
DIST pytest-xvfb-3.0.0.tar.gz 8607 BLAKE2B a1256b121a66c0b778a45f695754363ec241699197000f6237473dc2d54c0eeff499722073b00280ca242d695c192ff4fd985931a42bbb52a0f8e2424867b60a SHA512 9aec1681656badf81fbac3a0d621b163810001e155a1cb8fd35e0f8c8d3ee52556e622adc0468d8e7455b15ba0f5103622fae1aa2493a7053ca78f092e582cf1
-EBUILD pytest-xvfb-3.0.0.ebuild 746 BLAKE2B ca22d1831031c97976628e7b94ccac08a5fc04e70258bd2f063dfefc192686aecc1eee18c24db5f98963377ed16be6f26b928d259f31b4ac741eaf8cd34519fd SHA512 0b241b6cda6d18264fe4260b307b2c04d7dca24f76d3a2457e2b8d3b55c2596ec56a575c15d808bdfc6e528b536eab36a3bbd156436834c4432ec92a6ba61fba
+EBUILD pytest-xvfb-3.0.0.ebuild 704 BLAKE2B 6109d9e24390124577325d5f774d654af337089d4864d9d7575257acaaa2772dac000088a079fdee31ab2345654bacb4fdd38bf54ad4b6c899711da885b824fe SHA512 02bec7dfc210e4a9cd10d7469e4427664d22cfda65dbc16a23e25f3107f096609c3c5dea45dad2401f8ce4283adbc42ba1202964e802073d4b9edd6eaab4886d
MISC metadata.xml 408 BLAKE2B 514661a3043e602906bf900b7da93f0671fceb02ba2d54b5e781b6a68f583a03915e62944520a4900af78b0bc3a031036f18d766ab9c9833e92c031282be438f SHA512 849d377dbbeedff1a8d6afd613b2aeb21c5bb3d7825c141b3c53a395bc054cc1ac46e71e9404e2c3e2e22202d23da73bc40a74785c7c90189dbc9f5d04916577
diff --git a/dev-python/pytest-xvfb/pytest-xvfb-3.0.0.ebuild b/dev-python/pytest-xvfb/pytest-xvfb-3.0.0.ebuild
index 4f09bfae28da..d343380ff98b 100644
--- a/dev-python/pytest-xvfb/pytest-xvfb-3.0.0.ebuild
+++ b/dev-python/pytest-xvfb/pytest-xvfb-3.0.0.ebuild
@@ -1,20 +1,16 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
PYTHON_REQ_USE="tk"
-
inherit distutils-r1 pypi
DESCRIPTION="Pytest plugin to run Xvfb for tests"
-HOMEPAGE="
- https://github.com/The-Compiler/pytest-xvfb/
- https://pypi.org/project/pytest-xvfb/
-"
+HOMEPAGE="https://github.com/The-Compiler/pytest-xvfb/"
LICENSE="MIT"
SLOT="0"
@@ -31,5 +27,6 @@ distutils_enable_tests pytest
python_test() {
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
local -x PYTEST_PLUGINS=pytest_xvfb
+
epytest --runpytest=subprocess
}